runOrNotFunc returning false still has data being submitted

RESOLVED DUPLICATE of bug 658134

Status

P2
normal
RESOLVED DUPLICATE of bug 658134
8 years ago
2 years ago

People

(Reporter: Mardak, Unassigned)

Tracking

unspecified

Details

I'm looking through some initial results and some are missing metadata. I noticed that the ones missing study-specific metadata are reporting locations like pt-BR and de.

So the study is correctly not running:

  runOrNotFunc: function() {
    let channel = Services.prefs.getCharPref("app.update.channel");
    let locale = Services.prefs.getCharPref("general.useragent.locale");
    return channel != "release" && locale == "en-US";
  },

But somehow they are submitting generic metadata.
(Reporter)

Comment 1

8 years ago
Fyi, you can watch "test-pilot@mozilla-labs.bugs" to automatically get bugs relating to Test Pilot without having to be CC'd.

Comment 2

7 years ago
I wonder if this is related to the other bug you found, where 1.0.4 users would submit an empty event set even on studies that were supposed to be minimum 1.1.  Both runOrNot and minTPVersion are handled by the same code, which is not supposed to let the study run.

...but maybe there's an underlying bug where even a study that never ran can still be submitted?  That needs to be investigated.  Thanks for finding this problem.
Priority: -- → P2
Target Milestone: --- → 1.4
(Reporter)

Comment 3

7 years ago
Oh turns out these non-enUS submissions seem to all have old test pilot. Duping to bug 658134.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 658134
(Assignee)

Updated

2 years ago
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.