Last Comment Bug 658137 - Add API for iterating over the entire GC heap
: Add API for iterating over the entire GC heap
Status: RESOLVED FIXED
fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Bill McCloskey (:billm)
:
Mentors:
Depends on: 656261
Blocks: 571249
  Show dependency treegraph
 
Reported: 2011-05-18 18:10 PDT by Nicholas Nethercote [:njn]
Modified: 2011-05-23 14:16 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (6.23 KB, patch)
2011-05-18 18:10 PDT, Nicholas Nethercote [:njn]
n.nethercote: review+
Details | Diff | Review

Description Nicholas Nethercote [:njn] 2011-05-18 18:10:13 PDT
Created attachment 533491 [details] [diff] [review]
patch

This is spun off from bug 571249, which will use the API to count how much heap memory is used by object slot arrays and string characters.

I'm carrying over the r+ from Igor, and adding my own r+ for the minor changes that have happened since Igor's review (the per-kind and per-compartment restrictions, and hoisting the GetFinalizableTraceKind call out of the loop).
Comment 1 Nicholas Nethercote [:njn] 2011-05-18 18:13:57 PDT
If 656261 lands in the meantime, this patch'll need updating.

I really want to land this before cdleary does the TM-to-mc merge on Friday, so that bug 571249 can make it into Firefox 6.  Hopefully we three (njn, igor, billm) can co-ordinate things so this happens.
Comment 2 Igor Bukanov 2011-05-19 02:45:26 PDT
(In reply to comment #1)
> If 656261 lands in the meantime, this patch'll need updating.

It looks I need more work with the patch for the bug 656261. If I will fix it today, I will update the patch here as well. If not, just proceed with landing here.
Comment 3 Nicholas Nethercote [:njn] 2011-05-19 17:23:25 PDT
http://hg.mozilla.org/tracemonkey/rev/fc1369652e84
Comment 4 Chris Leary [:cdleary] (not checking bugmail) 2011-05-23 14:16:31 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/fc1369652e84

Note You need to log in before you can comment on or make changes to this bug.