Last Comment Bug 658177 - gVolumeScaleLock deadlock
: gVolumeScaleLock deadlock
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: mozilla6
Assigned To: Chris Pearce (:cpearce)
:
: Maire Reavy [:mreavy]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-18 22:31 PDT by Chris Pearce (:cpearce)
Modified: 2011-05-19 02:02 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (865 bytes, patch)
2011-05-18 22:31 PDT, Chris Pearce (:cpearce)
roc: review+
Details | Diff | Splinter Review

Description Chris Pearce (:cpearce) 2011-05-18 22:31:34 PDT
Created attachment 533538 [details] [diff] [review]
Patch

No good deed goes unpunished. I landed Bug 652475 today, but that introduced a potential deadlock with `make xpcshell-tests`. It never showed up on TryServer for some reason, but aborts locally for me with a warning about potential deadlock.

http://pastebin.mozilla.org/1229597

The problem is I take the gVolumeScaleLock  and then read the media.volume_sale pref. I imagine that's taking a lock.
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-18 22:39:15 PDT
Comment on attachment 533538 [details] [diff] [review]
Patch

Review of attachment 533538 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 2 Chris Pearce (:cpearce) 2011-05-19 02:02:30 PDT
http://hg.mozilla.org/mozilla-central/rev/7ef763ba534b

Note You need to log in before you can comment on or make changes to this bug.