All input fields are vertically size of 2 rows

RESOLVED DUPLICATE of bug 53492

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 53492
17 years ago
17 years ago

People

(Reporter: Lari Lohikoski, Assigned: waqar)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i586; en-US; 0.7) Gecko/20010111
BuildID:    2001011118

For a couple of days all <input>-fields in any web page have been too high.
Their height is something like two rows. I have removed and reinstalled mozilla,
but it hasn't helped. Also changing font size doesn't help. There is too much
empty space under the letters. However, the text cursor is of a size that is
correct to the size of the input box.

Textarea-fields are also a little bit problematic, the same problem applies also
there - just in a different form. In textareas when clicking into the area, the
cursor is of a correct size (=something like the size of the letters), but after
typing anything, the cursor resizes to be bigger - actually almost double.


Reproducible: Always
Steps to Reproduce:

Comment 1

17 years ago
probably a font or font metrics issue - reassigning
Assignee: rods → waqar
Summary: All input fields are vertically size of 2 rows → All input fields are vertically size of 2 rows

Comment 2

17 years ago
Can you tell us which theme you are using? Modern has changed not long ago to
use system fonts, so it may due to your system fonts. Also since nobody else has
reported this yet, you might want to see if using userChrome.css as described in
http://www.mozilla.org/unix/customizing.html helps.
Thanks,
Fabian.
Btw : Couple of days = two days, or more like one week?
(Reporter)

Comment 3

17 years ago
Created attachment 22871 [details]
The problem in question can be seen in this image.
(Reporter)

Comment 4

17 years ago
I have tried both schemes - the problem remains the same. However, using
userChrome.css was a good idea. When using the input-field example where for
example font-family is changed to clean and size to 13, the input field came out
with correct size. However, when changing the font to 'sans-serif', for example,
the problem reappeared.

As you can see in the example I attached, the same problem seems to come out
with all form fields - select-lists have also a bit too much space under the text.

'Couple of days' means something like two days - I'm not exactly sure.

Comment 5

17 years ago
Marking NEW as per reporters comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 6

17 years ago
This is the problem with TrueType fonts.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Assignee)

Comment 7

17 years ago

*** This bug has been marked as a duplicate of 53492 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.