Closed Bug 658254 Opened 9 years ago Closed 9 years ago

FireFox 4 hangs on confirmation pages in my PHP5 application

Categories

(Core :: DOM: HTML Parser, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: guy, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.8) Gecko/20100728 Firefox/3.6.8 (.NET CLR 3.5.30729)
Build Identifier: (FireFox 4.0 on all platforms)

I maintain a Free Software web application called eLAS (http://elas.vsbnet.be), written in PHP.

After the release of FF4, I started getting problem reports of users that can no longer perform some actions in the app on forms that use a normal HTTP POST method to confirm.

I can give you access to a demo version of the app as well as the required steps to reproduce (by private mail).  The webapp is in Dutch only unfortunately.

Reproducible: Always

Steps to Reproduce:
1.Open FF 4 on any platform
2.Surf to an eLAS installation
3.Log in
4.Choose Vraag/Aanbod
5.Choose verwijderen
6.Confirm deletion in the window


Actual Results:  
FF4 stops there, while FF3 and other browsers work correctly.

Expected Results:  
The window should close and the item should have been deleted.
Version: unspecified → 4.0 Branch
Does it make any difference if you set html5.parser.enable to false in about:config?
Sorry for the late reply.  Yes, it works again with this setting to false!
Considering comment2, setting resolution to Resolved WFM
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Hi Vlad, it works with that setting changed, but not with the FF default settings which most users will be using.  

eLAS advertises downloading FireFox when people visit with IE for which I only fix functional bugs, so I would like to offer them the best possible experience on your browser.

If this is caused by sloppy code by me, then I'll fix it, but having my pages work well on a default FF install is extremely important.
Could you please check if this is caused by incorrect code by me or by the new html5 parser?  I'm getting a flood of bug reports on this and I'd rather have it work on a clean FF install instead of letting end users play with settings, specially on the reference browser for eLAS.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Should it be possible to select "verwijderen", as described in step 5 in comment 0, in the demo at http://letsa.elas.vsbnet.be/ or do I need another user account?
@Thomas You can only select "Verwijderen" (which means delete) on entries that you own or as an admin.  I will send you an admin account on your gmail account.
Last good nightly: 2010-08-23 First bad nightly: 2010-08-24

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c48266f6fb10&tochange=9a623cc1c5e7
Your form looks something like this:

<form action='delete.php?id=49' method='POST'>
     <input type='submit' value='Verwijderen' name='zend'
</form>

There is no ">" at the end of the input tag. Does it make any difference if you add one?
Component: General → HTML: Parser
Product: Firefox → Core
QA Contact: general → parser
Version: 4.0 Branch → Trunk
Hardware: x86 → All
Ugh... comment 3 is way out of line.  Turning off the HTML5 parser does NOT make a bug WFM.

For the rest, comment 9 has found the exact problem, I bet.  See bug 638842 comment 9 for an analysis of how this markup works in HTML5.
See Also: → 638842
And the regression range in comment 8 includes the changeset that added the HTML5 handling for the "form" attribute of inputs.
I will try with the parser back on before and after adding the closing tag tomorrow.  It would be strange though as it happens on all confirmation forms.
It works now, did fixes on all popup dialogs and verified against FF 6
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.