If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

CLOSE_WAIT sockets never disappear. This was formerly reported, but I feel this is still a problem.

VERIFIED DUPLICATE of bug 62388

Status

()

Core
Networking: HTTP
VERIFIED DUPLICATE of bug 62388
17 years ago
17 years ago

People

(Reporter: INOUE Seiichiro, Assigned: Darin Fisher)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [ja] (X11; U; Linux 2.2.17 i686)
BuildID:    20000108

Bug 35636 was closed.
But I feel this is a still problem.
The original author seemed to be concerned about the number of CLOSE_WAIT
sockets.
My concern is that CLOSE_WAIT sockets never disappear under some conditions.

The followings might be the condition.
1. Use HTTP/1.1
2. No cache for the site.
3. Many(some?) images on the site.


Reproducible: Always
Steps to Reproduce:
1.Clear Mozilla's cache
2.Open http://www.netscape.com/
3.See sockets' status (e.g. netstat -tcnp on GNU/Linux).



Actual Results:  While you keep opening the window, the CLOSE_WAIT sockets never
disappear.


Expected Results:  I think Mozilla should close the socket, when the server
closes the other side of it.


From the server side's view, FIN_WAIT2 sockets remain.
They will disappear by the timeout.
I think the server keeps useless resources during waiting for the timeout.

Comment 1

17 years ago
Confirmed
Platform: PC
OS: Windows 98
Mozilla Build: 2001011904

This seems rather silly to let sockets hang around like that and could be used
as DoS. Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 2

17 years ago
this is really a regression of bug 35636, and as in that bug, the problem is
that while we do cache open socket connections, this problem indicates a leak
in the caching mechanism.  Socket transport bloat is bug 62388.  Marking dupe.

*** This bug has been marked as a duplicate of 62388 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.