Build id missing in window title

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: bugs4hj, Assigned: leaf)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I'm missing the build id in the windows title. Using build 20010117xx.
Did an reinstall, new profile also. But no luck. BTW, in preferences/category
pane debug is missing. Should it be like this??

Comment 1

18 years ago
WFM with build 2001011720 on NT4.
(Reporter)

Comment 2

18 years ago
Did install build 2001011804 so I'm about to close this bug. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 3

18 years ago
Wouldn't the correct resolution be worksforme?
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

18 years ago
Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
Yes, right, sorry for that.

Comment 7

18 years ago
Reopening; I fetched a 0130 build, and there is no build id in the window title.
Status: VERIFIED → UNCONFIRMED
Component: Browser-General → Build Config
Resolution: WORKSFORME → ---
Summary: Missing build id → Build id missing in window title

Comment 8

18 years ago
-> build config (hope that's the right component)
Assignee: asa → cls
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: doronr → granrose

Comment 9

18 years ago
details.  what file and where are you getting it from?  I suspect you're taking
the build from the "latest" directory and getting some test branch builds we've
been doing lately that are based on the old Netscape_20000922_BRANCH branch. 
Make sure you're getting your bits from the dated directory (i.e.
2000-01-30-08-Mtrunk) and try it again.

this is most likely WFM, but I'll wait to hear from the reporter before resolving.
Assignee: cls → leaf

Comment 10

18 years ago
You're right - I'm always downloading from the "latest" directory, because
it's very convenient. I'm always fetching
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip

I wouldn't want to look first what the latest dated directory is.
Is there another symlink to that directory? Or is there a bug about its absence?
(Assignee)

Comment 11

18 years ago
there is a bug filed against me (which is low on the list of things to do) to 
keep branch builds from stuffing into latest.
(Reporter)

Comment 12

18 years ago
The name "latest" implies that this would be the right thing to download, if you
want to have the LATEST build. But that far from being true.
(Assignee)

Comment 13

18 years ago
that's completely subjective. *latest* by definition, means "most recent". 
Chronologically, the builds that are going into latest are *always* the most 
recent builds performed. Not "latest source from the trunk," but, "last built."

I think what we may do is add a prefix to latest, like <BRANCH>-latest.
So that |latest| will be replaced with |trunk-latest| or |test-latest|... but 
that's another bug that already has been filed. Keep your shirt on.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID

Comment 14

18 years ago
Yes, please use another directory for the test builds! That can be only a matter
of a few minutes to fix, I suppose.

New builds in the "latest" directory are announced on IRC by bots all the time,
why do you do that if it's just useless?

If you find that other bug, please tell me.

I and others wrote/reopened at least three bugs (this one, bug 67167 and
bug 38280) because of this. This is a waste of time! If you find that
other bug about this, please tell me.
(Assignee)

Comment 15

18 years ago
It's not just useless; and it takes more than a few minutes to fix, because 
guess what? writing to the latest directory is a generic thing, done by every 
script. How is one build supposed to know it's supposed to write to the generic 
"latest" in chronological order directory?

I believe i'm going to solve the problem by getting rid of latest altogether, 
and perhaps reimplementing a latest-<branch> push.

Comment 16

18 years ago
Please don't get rid of latest!  A lot of people have bookmarks, links on web
pages or similar to that directory.  This would break all of them.
See bug 67445 for more comments from me.

Verified invalid.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 17

18 years ago
That should be Worksforme, it was a valid bug.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 18

18 years ago
Selecting Worksforme
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 19

18 years ago
You're right, verifying again.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.