NPP_Print never fired for out-of-process plugins (ipc enabled)

RESOLVED DUPLICATE of bug 638796

Status

()

RESOLVED DUPLICATE of bug 638796
7 years ago
7 years ago

People

(Reporter: zeniko, Unassigned)

Tracking

({regression})

2.0 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Steps to reproduce:
1. Install any PDF plugin (e.g. Adobe's or SumatraPDF's, probably Foxit's as well).
2. Load a PDF document in a tab (any from http://www.google.com/search?q=filetype%3Apdf will do).
3. Firefox-Button -> Print (or hit Ctrl+P while the address bar is focused)

Expected result:
The plugin's Print dialog appears.

Actual result:
Nothing happens.

Setting dom.ipc.plugins.enabled to false makes this work (making this is a regression from Firefox 3.6 where IPC wasn't enabled by default).

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 638796
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.