Uninitialised value use in nsTextFrame::AddInlineMinWidthForFlow

RESOLVED DUPLICATE of bug 655207

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 655207
7 years ago
7 years ago

People

(Reporter: jseward, Unassigned)

Tracking

({valgrind})

Trunk
x86_64
Linux
valgrind
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
This is mozilla-aurora of 19 May 2011, w/ a crashtest:
layout/generic/crashtests/645072-2.html

Conditional jump or move depends on uninitialised value(s)
   at 0x58ADA0E: nsTextFrame::AddInlineMinWidthForFlow(nsIRenderingContext*, nsIFrame::InlineMinWidthData*) (layout/generic/nsTextFrameThebes.cpp:6167)
   by 0x58ADF00: nsTextFrame::AddInlineMinWidth(nsIRenderingContext*, nsIFrame::InlineMinWidthData*) (layout/generic/nsTextFrameThebes.cpp:6210)
   by 0x583A965: nsBlockFrame::GetMinWidth(nsIRenderingContext*) (layout/generic/nsBlockFrame.cpp:762)
   by 0x57FC190: nsLayoutUtils::IntrinsicForContainer(nsIRenderingContext*, nsIFrame*, nsLayoutUtils::IntrinsicWidthType) (layout/base/nsLayoutUtils.cpp:2234)
   by 0x5823CFB: nsFieldSetFrame::GetIntrinsicWidth(nsIRenderingContext*, nsLayoutUtils::IntrinsicWidthType) (layout/forms/nsFieldSetFrame.cpp:366)
   by 0x5823C99: nsFieldSetFrame::ComputeSize(nsIRenderingContext*, nsSize, int, nsSize, nsSize, nsSize, int) (layout/forms/nsFieldSetFrame.cpp:405)
   by 0x5871A18: nsHTMLReflowState::InitConstraints(nsPresContext*, int, int, nsMargin const*, nsMargin const*) (layout/generic/nsHTMLReflowState.cpp:1867)
   by 0x58724E2: nsHTMLReflowState::Init(nsPresContext*, int, int, nsMargin const*, nsMargin const*) (layout/generic/nsHTMLReflowState.cpp:284)
   by 0x5842CA2: nsBlockReflowContext::ComputeCollapsedTopMargin(nsHTMLReflowState const&, nsCollapsingMargin*, nsIFrame*, int*, int*) (layout/generic/nsBlockReflowContext.cpp:185)
   by 0x583D330: nsBlockFrame::ReflowBlockFrame(nsBlockReflowState&, nsLineList_iterator, int*) (layout/generic/nsBlockFrame.cpp:3069)
   by 0x583EE28: nsBlockFrame::ReflowLine(nsBlockReflowState&, nsLineList_iterator, int*) (layout/generic/nsBlockFrame.cpp:2506)
   by 0x583F784: nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&) (layout/generic/nsBlockFrame.cpp:1999)

 Uninitialised value was created by a stack allocation
   at 0x58AD653: nsTextFrame::AddInlineMinWidthForFlow(nsIRenderingContext*, nsIFrame::InlineMinWidthData*) (layout/generic/nsTextFrameThebes.cpp:6063)
Looks like it might be a dup of bug 655207?
(Reporter)

Comment 2

7 years ago
Yes, it is.  Closing.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 655207
You need to log in before you can comment on or make changes to this bug.