Page scrolling using the scrollbar on new twitter scrolls too many lines

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
7 years ago
a year ago

People

(Reporter: David Jameson, Unassigned, NeedInfo)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(platform-rel -)

Details

(Whiteboard: [platform-rel-Twitter], URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When you do a page scroll using the scrollbar (click below the scrollbar handle) while on twitter, it scrolls one line too many and you have to scroll back up again. Scrolling using the pageup/pagedown keys on the keyboard works perfectly. The problem only happens with #newtwitter.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.twitter.com (make sure you have #newtwitter enabled)
2. Click under the scrollbar handle to scroll down a page


Actual Results:  
It actually scrolls 1 line too much

Expected Results:  
Should scroll 1 page. If you use pageup/pagedown keys it scrolls perfectly.

Works perfectly on Chrome and IE9.
Version: unspecified → 4.0 Branch
I am unable to reproduce this issue on: 
Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110523 Firefox/6.0a1

Reporter, please can you confirm whether this issue still occurs using Firefox with a clean profile?
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile
(Reporter)

Comment 2

7 years ago
Yes, I just tried and it still happens on a new profile. Also it happens on both my XP and Vista machines so it's not an issue on my computer. Try clearing your cookies (so that twitter displays the 'welcolme to #newtwitter' bar as well as the newtwitter bar) before logging into your twitter account and the problem is even more apparent (it misses out more lines when scrolling, and it even occurs when using pageup/pagedown keys).

Also I just tried the 6.0a1 nightly build and the problem occurs in that version as well.
Can you attach some marked & anonymized Screenshots making the Issue more clear perhaps?
(Reporter)

Comment 4

7 years ago
I have captured a Jing screencast here:

http://screencast.com/t/sNN8TT3lxZ

You can see I am selecting some text at the bottom of the window, then clicking under the scrollbar to scroll down 1 page. You can see it misses out about 3 or 4 lines (i.e. scrolls 3 or 4 lines too much) and I have to scroll back up a few lines.
Okay, I see that the scrolling into View is off by one Entry, i.e. your mentioned 3-4 Lines, too on Trunk.

Opera 11.50 Build 1015 behaves like Gecko here. Unsure who's right.
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: 4.0 Branch → Trunk
Whiteboard: [platform-rel-Twitter]
platform-rel: --- → ?
David, do you still see this problem happening in current Twitter?
Flags: needinfo?(davidj)
(Reporter)

Comment 7

a year ago
I just tested, and it seems to be working perfectly now. I've just marked it as resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Perfect, thanks! :-)
platform-rel: ? → -
You need to log in before you can comment on or make changes to this bug.