if followed link cannot be loaded, url control is updated

VERIFIED FIXED in M8

Status

SeaMonkey
UI Design
P2
normal
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: cpratt, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
build id: 1999051408
platform: windows nt

to reproduce: load a page with a link on it that goes to a bad url. as of 2.10
pm today, you could go to aol.com and have any number of links not work because
dynamic.aol.com was down, for example. on that page, click a link that won't
work. result: the link does not load, and yet the location control is updated to
reflect the url that you attempted to load. expected result: the location
control is not updated and still shows you the page you're viewing.

Updated

19 years ago
Assignee: trudelle → don

Comment 1

19 years ago
The location bar is an XPApp control, reassigning to don

Updated

19 years ago
Assignee: don → radha
Component: XP Toolkit/Widgets → other
Target Milestone: M7

Comment 2

19 years ago
Radha, is this our bug or a netlib problem?
Status: NEW → ASSIGNED
It is mine.

Updated

19 years ago
Component: other → XPApps
Priority: P3 → P2
Target Milestone: M7 → M8

Comment 4

19 years ago
Move this to M8 ...
I can't reproduce this in today's build. Please verify. I used this little
sample file to test this.

<html>
<head>
  <title> My  Home Page </title>
</head>

<p>
<a href="test.html">Click here to go nowhere</a>
</body>
</html>

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
it looks good to me on
     1999-06-16-08 RedHat Linux 5.2 kernel 2.2.7
     1999-06-16-08 WinNT 4.0 sp4
     1999-06-16-08 MacOS 8.51

now the behavior is as follows:

if a url is invalid, the url bar is updated for that url and the server
will give you a 404 or some other Not Found error. that is on par with 4.x.

i'm marking fixed and verified.
(reopen if you think the behavior should be different)
(Reporter)

Comment 7

19 years ago
phillip, that test case (http://wetnap/seamonkey/bugs/bug6586.html) could be
updated to contain links to servers that don't exist (steal the page at
http://schist/bug6586.html if you'd like). anyhoo, using the june 16 build under
nt, it now works just great for me. (if a link to a server that doesn't exist or
doesn't load is followed, the url is not updated.)
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.