FeedWriter keeps objects alive through its prototype

RESOLVED INVALID

Status

()

Firefox
RSS Discovery and Preview
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: peterv, Assigned: peterv)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 534074 [details] [diff] [review]
v1

FeedWriter holds a number of XPCOM objects alive through its prototype. These shouldn't live on the prototype, but on the instances. The prototype stays alive until shutdown, so it leads to bloat and sometimes to leaks because the CC can't collect any cycles involving objects held by FeedWriter.prototype.
(Assignee)

Updated

7 years ago
Attachment #534074 - Flags: review?(jonas)
Comment on attachment 534074 [details] [diff] [review]
v1

rs=me, though I really don't understand why this fixes things. Would love an explanation for that.
Attachment #534074 - Flags: review?(jonas) → review+
(Assignee)

Comment 2

7 years ago
I can't reproduce this anymore, so let's not do this since we don't understand how it could fix anything.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Assignee)

Updated

7 years ago
Attachment #534074 - Flags: review+ → review-
You need to log in before you can comment on or make changes to this bug.