Drop Downs are missing Men's and Gray

RESOLVED FIXED

Status

mozilla.org
Webdev
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Heather Leson, Unassigned)

Tracking

(Depends on: 1 bug)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: 

The Drop Down menus on the Join site are missing options: Men's and the colour Gray

Reproducible: Always
(Reporter)

Updated

7 years ago
Depends on: 649698
Email thread...

The items are there in the dropdown but the last option in each shows up blank for some reason (Men's, XXL, Grey).

---

No luck on our side tracking this down yet. Have you reached out to BSD yet to see if they've implemented any changes (especially with respect to JavaScript)?

This obviously tested OK in staging and prod at one point, and we haven't made any changes, so we're a little suspicious...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 534088 [details]
screenshot of join mozilla form in chromium and ff4

This appears to be either sporadic or resolved. See attached screenshot, select elements are populated with (Men's, Women's), (Small, Medium, Large, XL, XXL), (Blue, Black, Grey).
(Reporter)

Comment 3

7 years ago
Just tested. Men's is back. Gray is still missing.
(In reply to comment #3)
> Just tested. Men's is back. Gray is still missing.

so it's sporadic :)
Hi guys, we're doing some testing in production (again, since this happens in no other environment).

For a quick workaround, we're looking to just insert a blank item at the end of each drop-down. Hence, this is why you see 'Mens' showing up right now.

>Gray is still missing.

And so is XXL, this is not isolated to just two fields. This is a programmatic issue recently introduced that displays the last item in the drop down as blank. Let me know if you have questions on this.
We believe this workaround (adding an additional 'blank' field to the dropdowns) is the best solution until confirmed with BSD that something has been introduced that's conflicting with this loop.

Paul, would you like us to reach out directly?
(In reply to comment #6)
> We believe this workaround (adding an additional 'blank' field to the
> dropdowns) is the best solution until confirmed with BSD that something has
> been introduced that's conflicting with this loop.
> 
> Paul, would you like us to reach out directly?

Hi Devin, it's non-destructive, so go ahead and make the change if you think it'll help in the short-term.
Cool, it's been in place since our last update...
(Reporter)

Comment 9

7 years ago
This has long been confirmed as handled.
I can see this live at join.mozilla.org.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.