ccache is off on linux 64 builds

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: espindola, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

I noticed that 32 bit builds use ccache, but 64 bit don't.

Updated

7 years ago
Component: Build Config → Release Engineering
Product: Core → mozilla.org
QA Contact: build-config → release
Version: Trunk → other
Created attachment 534090 [details] [diff] [review]
Enable ccache on linux64

this will have to wait until next week to deploy
Attachment #534090 - Flags: review?(bhearsum)
mozconfigs also need updating
Attachment #534090 - Flags: review?(bhearsum) → review+

Comment 3

7 years ago
Please re-assign if you see fit.
Assignee: nobody → catlee
(Assignee)

Comment 4

7 years ago
Created attachment 535392 [details] [diff] [review]
Add ccache to linux64 mozconfigs

Decided to help catlee out. Hoping to get this landed this week instead.

A big patch, but it's just adding ccache to the options on all the linux64 mozconfigs.
Attachment #535392 - Flags: review?(bhearsum)
(Assignee)

Updated

7 years ago
Attachment #534090 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Assignee: catlee → coop
Status: NEW → ASSIGNED
Priority: -- → P2
Comment on attachment 535392 [details] [diff] [review]
Add ccache to linux64 mozconfigs

I don't think this is the right way to turn it on. On 32-bit Linux we use:
REAL_CC=/tools/gcc/bin/gcc
REAL_CXX=/tools/gcc/bin/g++

CC="ccache $REAL_CC"
CXX="ccache $REAL_CXX"

We don't use ccache for release builds for 32-bit, so let's stay consistent here.

I think you missed a few mozconfigs too: eg, mozilla-1.9.2 nightly/debug.
Attachment #535392 - Flags: review?(bhearsum) → review-
(Assignee)

Updated

7 years ago
Duplicate of this bug: 601880
(Assignee)

Comment 7

7 years ago
Created attachment 535451 [details] [diff] [review]
Add ccache to linux64 mozconfigs, v2

OK, I think I've unraveled this now.

1.9.1 and 1.9.2 need the |CC="ccache $REAL_CC"| style declaration, everything else needs |ac_add_options --with-ccache=/usr/bin/ccache|.

Also, we don't use ccache for releases or debug builds on 32bit linux, so don't turn it on for 64bit either.
Attachment #535392 - Attachment is obsolete: true
Attachment #535451 - Flags: review?(bhearsum)
Attachment #535451 - Flags: review?(bhearsum) → review+
(Assignee)

Comment 8

7 years ago
Comment on attachment 535451 [details] [diff] [review]
Add ccache to linux64 mozconfigs, v2

http://hg.mozilla.org/build/buildbot-configs/rev/2c54d5d80de9
Attachment #535451 - Flags: checked-in+
(Assignee)

Updated

7 years ago
Flags: needs-reconfig?
(Assignee)

Comment 9

7 years ago
Merged to production today.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: needs-reconfig? → needs-reconfig+
Resolution: --- → FIXED
Blocks: 759076
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.