If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

no way to retrieve forgotten username

VERIFIED FIXED in 2012-01-31

Status

support.mozilla.org
Users and Groups
--
trivial
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sdaugherty, Assigned: rrosario)

Tracking

unspecified
2012-01-31

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=users s=2012.2 p=2)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
We have a forgot password function, but no forgot username, so there's no way short of contacting a site admin to retrieve a forgotten username.

Since sumo asks for an email address in order to send out a forgotten password, one possible fix would be to rename the forgot password function to forgot username or password, and include the username when sending a password reset message.

Updated

6 years ago
Duplicate of this bug: 696554
Duplicate of this bug: 706793

Comment 3

6 years ago
Can we bump up the prio on this please? Every week we get incoming requests from users, forwarded by Terry to sumo-dev@mozilla.com -- two just today.
(Assignee)

Updated

6 years ago
Whiteboard: u=user c=users s=2012.2 p=
Target Milestone: --- → 2012Q1

Comment 4

6 years ago
Created attachment 587403 [details]
UX flow - username recovery

User experience flow for username recovery.

I’m reusing the existing Login and Password Recovery dialogs, appending texts where necessary.
Comment on attachment 587403 [details]
UX flow - username recovery

Do we need to have a second page that does the same thing as Password Isn't Working, or can we combine them somehow?

Comment 6

6 years ago
(In reply to James Socol [:jsocol, :james] from comment #5)
> Do we need to have a second page that does the same thing as Password Isn't
> Working, or can we combine them somehow?

I don’t think we can combine them, since the two pages do two separate things (even though they both take the same input).
(In reply to Bram Pitoyo [:bram] from comment #6)
> I don’t think we can combine them, since the two pages do two separate
> things (even though they both take the same input).

Then we need a definition--including email copy, if any--for what the forgotten username page does.

Comment 8

6 years ago
Short description:
The forgot username page allows user to input his email address and get a username reminder email.

Steps:
1. User inputs his email address on a field and hit “Send Username” button
2. Check whether SUMO has a record of the user’s account
3a. If no, refresh the page and print a message above the email field: “Sorry, you mistyped your email address or don’t have an account yet. Enter your email address again or [register]” (link to Register page at https://support.mozilla.org/en-US/users/register)
3b. If yes, continue to next page and print “We've sent an email to this address with your username inside”
4. Send an email

Title: Your username on support.mozilla.org

Body:
We’ve just received a request to send the username linked to this email address.

Your username is:
bram

You may log in at http://support.mozilla.org/users/login

If you did not request this email, there is no need for further action.


Thanks,
The support.mozilla.org team
(Assignee)

Updated

6 years ago
Whiteboard: u=user c=users s=2012.2 p= → u=user c=users s=2012.2 p=2
(Assignee)

Updated

6 years ago
Assignee: nobody → rrosario
(Assignee)

Comment 9

6 years ago
(In reply to Bram Pitoyo [:bram] from comment #8)
> 3a. If no, refresh the page and print a message above the email field:
> “Sorry, you mistyped your email address or don’t have an account yet. Enter
> your email address again or [register]” (link to Register page at
> https://support.mozilla.org/en-US/users/register)

We are very careful everywhere about not leaking existence of email addresses registered on the site. What we do for password reset is indicate that we have emailed any users registered with the given email, without indicating if a user was found or not. I'll do the same here.
(Assignee)

Comment 10

6 years ago
https://github.com/mozilla/kitsune/commit/448c35c30857dc158a2dd41f8ad9071159adba85
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: 2012Q1 → 2012-01-31
(Assignee)

Comment 11

6 years ago
FTR: I finished this faster than I had expected but it was still more than "half a day". So, I'd say it was on the lower end of a 2pter.
Verified user gets sent message even with a bad username, verified receipt of username email with correct text & links.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.