If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thin white stripes appear when loading large, downscaled image

RESOLVED DUPLICATE of bug 703231

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 703231
6 years ago
2 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Assigned: Joe Drew (not getting mail))

Tracking

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox6-)

Details

(Whiteboard: [dupeme] [jesse nominated in comment 3])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 534185 [details]
Screenshot

This is similar to bug 416217, although the white stripes I saw were much thinner (see attached screenshot).

STR:

 * Open http://upload.wikimedia.org/wikipedia/commons/6/6e/USGS_Rikers_Island.png

The image does not load smoothly for me, and I tend to get a stripe where the progressive loading pauses and where the loading jumps to when it resumes.

Zooming the image to 100% removes the bars.  They're still gone when I zoom back out.  Switching to another tab and back to the image also removes the bars.
(Reporter)

Comment 1

6 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110520 Firefox/6.0a1

ATI Technologies Inc. -- ATI Radeon HD 6750M OpenGL Engine -- 2.1 ATI-1.6.34
GPU Accelerated Windows 1/1 OpenGL
(Reporter)

Comment 2

6 years ago
I don't see white bars at [1], the image linked in bug 416217.

[1] http://www.mozilla.org/quality/browser/front-end/testcases/drag-drop/drag-bigimg-from-browser/p43886.jpg

Comment 3

6 years ago
I ran into this bug while surfing porn :(

It seems to only happen at certain scaling factors. Here's a testcase that includes a scaling factor, to make it easier to reproduce:

http://www.squarefree.com/bug658731/
tracking-firefox6: --- → ?
Summary: Thin white stripes appear when loading large png → Thin white stripes appear when loading large, downscaled image

Comment 4

6 years ago
Is this Mac OS X only? I cannot reproduce on Windows 7.
I believe so, yes.

Updated

6 years ago
Whiteboard: dupeme → dupeme jesse nominated in comment 3

Updated

6 years ago
tracking-firefox6: ? → +

Comment 6

6 years ago
Joe, this is a regression that we'd like to get a handle on for Aurora. Can you help us out?
Assignee: nobody → joe
Keywords: regressionwindow-wanted
(Assignee)

Comment 7

6 years ago
I don't think this is a regression. At least, it appears in Firefox 4 and probably in 3.x as well. I question it being tracked for fx6.
tracking-firefox6: + → ?

Comment 8

6 years ago
Agreed. The tracking as based on the assumption that this was a recent regression. Minus unless we find out that it is.
tracking-firefox6: ? → -

Updated

6 years ago
Whiteboard: dupeme jesse nominated in comment 3 → [dupeme] [jesse nominated in comment 3]

Comment 9

6 years ago
I can reproduce in Firefox 4 as well.  I guess it's just a coincidence that jlebar and both discovered it last week.  Sorry for the incorrect nomination.
My theory is that this is caused by the larger filter kernel that CoreGraphics uses when sampling images. i.e. we are sampling from a larger area than we invalidate.

Comment 11

6 years ago
Same as / similar to bug 522687?
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 703231
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.