Links to non-available locales at https://www.mozilla.com/en-US/firefox/all-beta.html

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: Aleksej, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
https://www.mozilla.com/en-US/firefox/all-beta.html contains links to localized builds which are not available, some of which are:
* ak
* bg
* bn-BD
product-details seems to be out of sync with the list of locales that were built. Compare http://viewvc.svn.mozilla.org/vc/libs/product-details/firefoxDetails.class.php?revision=89158&view=markup
with http://hg.mozilla.org/releases/mozilla-beta/file/FIREFOX_5_0b2_RELEASE/browser/locales/shipped-locales

If I were to hazard a guess I'd say all the LATEST_FIREFOX_VERSION lines got copied to LATEST_FIREFOX_DEVEL_VERSION without checking the locales needed.
Severity: normal → major
OS: Linux → All
Created attachment 534217 [details] [diff] [review]
Potential patch

This patch is just from inspection of the arrays, don't know how I can test this properly. Are there any tools we can use to verify against the list of shipped-locales in hg ?
Attachment #534217 - Flags: review?(anthony)

Updated

8 years ago
Duplicate of this bug: 658873
Comment on attachment 534217 [details] [diff] [review]
Potential patch

Review of attachment 534217 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks a lot Nick !
Attachment #534217 - Flags: review?(anthony) → review+

Comment 5

8 years ago
I'd expect to see Kazakh, kk, to be added, at least.
Right and es-CL too.

Committed r89286 and r89287 to product-details to fix that.

CCing Christian so we can put this task in the process for the next release.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: push-needed
Resolution: --- → FIXED

Updated

8 years ago
Keywords: push-needed → qawanted
qa-verified-trunk https://www-trunk.stage.mozilla.com/en-US/firefox/all-beta.html
Keywords: qawanted
(Assignee)

Updated

7 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.