Closed Bug 658788 Opened 9 years ago Closed 8 years ago

Icons are created at the wrong place when drag'n'droping images to the desktop

Categories

(Firefox :: General, defect)

5 Branch
x86_64
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 401380

People

(Reporter: dontspammeever, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0a2) Gecko/20110414 Firefox/5.0a2
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0a2) Gecko/20110414 Firefox/5.0a2

When I drag'n'dropping an image from a webpage to the desktop, the icon is placed at the first available place (going from up-down/left-right) and not where I dropped it.
Curiously, links icons are created at the right place : drag'n'drop a link from a webpage or the favicon of the adress bar and the icon is where you want it to be.
The same behavior is expected with images.

Reproducible: Always

Steps to Reproduce:
1. drag'n'drop an image from the browser to the desktop

Actual Results:  
Now your icon is somewhere on the desktop, look for it. yep, i know you moved it next to the dock to reuse it instantly but it's hidden behind the browser, ah ah.

Expected Results:  
the icon should be where i dropped it.
Version: unspecified → 5 Branch
Reproducible for me on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110523 Firefox/6.0a1

Setting resolution to NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401380
You need to log in before you can comment on or make changes to this bug.