Image-heavy pages use too much memory while loading

RESOLVED DUPLICATE of bug 542158

Status

()

RESOLVED DUPLICATE of bug 542158
8 years ago
6 years ago

People

(Reporter: john.s.peterson, Unassigned)

Tracking

(Blocks: 1 bug, {memory-footprint})

4.0 Branch
x86_64
Windows 7
memory-footprint
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0.1) Gecko/20110430 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0.1) Gecko/20110430 Firefox/4.0.1

These pages have many images and use too much ram:
http://www.militaryphotos.net/forums/showthread.php?99988-Russian-Photos-%28updated-on-regular-basis%29/page2737
http://www.mapcrunch.com/gallery
http://www.9-eyes.com/
http://www.theatlantic.com/infocus/2011/03/air-strikes-on-libya/100031/

Comparison between browsers in terms of Private Working Set ram:

Site                                    FF x86    FF x64    IE x64    GC x86
http://www.mapcrunch.com/gallery        1.1 GiB   0.7 GiB   0.1 GiB   0.2 GiB
http://www.militaryphotos.net/...       0.9 GiB   0.9 GiB   0.1 GiB   0.8 GiB
-all four pages above-                            2.1 GiB   0.3 GiB   1.2 GiB
-25 mapcrunch pages-                              6.9 GiB   1.1 GiB   2.0 GiB

I know that tab memory is cleared after the tab has been idle for about a minute, but even while viewing the page the memory usage should be as small as in IE.

Reproducible: Always

Steps to Reproduce:
Open the webpage

Actual Results:  
Memory usage is high

Expected Results:  
Memory usage should be low
(Reporter)

Updated

8 years ago
Keywords: footprint

Updated

8 years ago
Version: unspecified → 4.0 Branch
Probably partly (or more) the same as bug 542158
Marking as depends on bug 542158 since I'm not certain this is a full dup
Depends on: 542158
Blocks: 683284
No longer depends on: 542158
Bug 689623 improved this significantly.  I just tested http://www.militaryphotos.net/forums/showthread.php?99988-Russian-Photos-%28updated-on-regular-basis%29/page2737.

Before bug 689623, about:memory's "images/contents/used/uncompressed-heap" number was 249 MiB once the page finished loading, and it stayed there so long as you didn't leave the tab.

After bug 689623, that same measurement peaked at 249 MiB immediately after loading, but then dropped to 30 MiB within about 20 seconds.  When I scrolled to the bottom of the page quickly it jumped back up to ~249 MiB, and then again dropped, this time to 12 MiB, after about 20 seconds.

The high memory consumption while scrolling quickly seems reasonable to me.  The high memory consumption during page loading is sub-optimal, though.
Summary: Images use too much ram → Image-heavy pages us
Summary: Image-heavy pages us → Image-heavy pages use too much memory while loading
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542158
You need to log in before you can comment on or make changes to this bug.