Two popup windows, forbidden, jumped and my choice in a menu was interrupted

RESOLVED DUPLICATE of bug 658911

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 658911
7 years ago
5 years ago

People

(Reporter: Nicolas Barbulesco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

My options are set to block popups and not to allow the 3 available Javascript wrongdoings.

On top of that, I have set the about:config option to open links in the current tab. Which, first, should not be such a hidden option — apparently it was a visible one in some previous Firefox — and, secondly, should be the default behaviour.

So no unsolicited tab must ever come to life.

I encountered two unsolicited tabs.

This is unacceptable.

Please make Firefox more pleasant to use by fixing this behaviour.


Reproducible: Always

Steps to Reproduce:
1. I create a Firefox window.
2. In the new window, I go to the address www.pany-direct.com .
3. I select some text in the page or I just click in the background in the page.
4. I create a Firefox window.
5. In the new window, I go to the address www.worldlingo.com/products_services/worldlingo_translator.html .
6. I click on the From menu to choose a language.


Actual Results:  
After step 3, a stupid popup window jumps.
After step 6, a stupid popup window jumps and I am kicked out of the menu, so I have to click again on the menu to choose the language.


Expected Results:  
Peace and respect.

No aggression.

No kicking out of my activity.


Firefox 4.0.1 Windows.
(Reporter)

Comment 1

7 years ago
Thanks in advance,

Nicolas

Comment 2

7 years ago
Cannot reproduce on the first URL, but the second one does open a window on clinking the select element.

Very similar to Bug 658911.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 658911
(Reporter)

Comment 3

7 years ago
This is a little different than the other bug.

This bug is even worse than the other bug. Here I don't click on a link nor anything which is supposed to have an action.

Comment 4

7 years ago
I think almost any element can hook the click event to open a new window. The fact is, you clicked on it. If you don't click, the site doesn't force the window on you. If you don't like the window on click, don't use the site if its content doesn't fit you. FF popup protection is designed only to protect against windows that open even without you clicking anything.
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)

> I think almost any element can hook the click event to open a new window.

In this case, the browser obeys too much the page and does not put enough the user in control. Which is, according to my sensitivity and to usability literature, very bad.

IE 8 does not that. Instead, it displays the yellow bar, in order to allow the user to show the blocked page if he really wants to. Which is a much better behaviour.

> If you don't like the window on click, don't use the site
> if its content doesn't fit you.

...Or use it with a decent browser.

There are other criteria for deciding whether using the site. Sometimes, you have no choice. Sometimes, you really need or want to use the site.

Furthermore, you don't know the site is bad behaving until you fall victim of its trap.
And sites can change. They don't welcome you trustably "I'm safe." nor "Avoid me."
You even are attracted to the trap by a legitimate-appearing bait. I just saw a popup window opening in Firefox because of that trick. The ad on a page shows a - sometimes fake - "Close" link or cross. I click on it to close the ad, and that click triggers a popup window!

> FF popup protection is designed only to
> protect against windows that open even without you clicking anything.

In that case, that's not what Firefox advertises, and that's really not enough protection.

Some "protection feature" should not even be needed. Web browsers have evolved in the wrong way. They have included all kind of flaws: Javascript, "target" attribute... And now they are building stronger and stronger "blockers" around them. A much simpler and safer design would be: not to provide to the page any way to interact out of its frame, except in a few specific cases, safely handled and user-controlled.

Comment 6

7 years ago
Yes, I understand. So please open an ENHANCEMENT request to propose a stricter blocking function, as mentioned in Bug 658911. Actually, I can do it for you, wait a moment.

Comment 7

7 years ago
Done, bug 660308.
Depends on: 660308
(Reporter)

Updated

5 years ago
Blocks: 86194

Updated

5 years ago
No longer blocks: 86194
You need to log in before you can comment on or make changes to this bug.