I move the Firefox window to the left edge of the screen. When reopening FF, window is not reopened at previous location

RESOLVED DUPLICATE of bug 659146

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 659146
7 years ago
7 years ago

People

(Reporter: cbramdit, Unassigned)

Tracking

4.0 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

It's reopened at around 20px to the right of the left screen edge

Reproducible: Always

Steps to Reproduce:
1. Open FF
2. Move the window so that the left of the window is exactly at the left screen edge
3. Close FF
4. Reopen FF

Actual Results:  
The window is moved a bit to the right

Expected Results:  
The window should be reopened at the exact location when FF was closed
(Reporter)

Updated

7 years ago
Version: unspecified → 4.0 Branch
(Reporter)

Comment 1

7 years ago
Only happens if the window is located at the very top of the screen.

Comment 2

7 years ago
I could not reproduce the issue on:
 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110522 Firefox/6.0a1

*Note: Can you attach a screenshot of the issue? Considering the steps described it seems that this is a corner case.
(Reporter)

Comment 3

7 years ago
This issue actually happens on only 1 of my computers.

Upon restart of FF, it seems that the window is located as if I had opened a new window (Ctrl+N) (with the first window located at the edge of the screen). So I guess FF didn't register that the first window was closed. I will do a video, and check if the FF process really died between closing the window and restarting.
(Reporter)

Comment 4

7 years ago
Duplicate of #659146
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 659146
You need to log in before you can comment on or make changes to this bug.