The default bug view has changed. See this FAQ.

Thumbnails for to-be-restored tabs are not rendered

RESOLVED FIXED

Status

Firefox Graveyard
Panorama
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: ttaubert, Unassigned)

Tracking

Dependency tree / graph

Details

(Whiteboard: [qa+])

(Reporter)

Description

6 years ago
Since the landing of bug 595601 thumbnails for to-be-restored tabs aren't rendered anymore.
(Reporter)

Updated

6 years ago
Depends on: 595601
(Reporter)

Comment 1

6 years ago
Very strange. The session works in my trunk build but does not work in my up-to-date nightly. I get "Error while loading thumbnail" all the time.
(Reporter)

Comment 2

6 years ago
When opening all pages the disk cache grew up to 1.5GB and suddenly everything was lost. Seems to work now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

6 years ago
Doesn't work for me :( We should investigate this.
Blocks: 660175
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Updated

6 years ago
Duplicate of this bug: 660400
(Reporter)

Comment 5

6 years ago
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Tim: Do you still see the issue?
Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0

I stumbled upon this issue while doing Beta upgrades to Firefox 8 from previous Firefox versions.

I can reproduce this on all platforms when upgrading from any Firefox 4 beta to Firefox 8 beta2 with a clean profile. The thumbnails from groups are not rendered unless the respective group is loaded.

When upgrading from Firefox 5 or a newer version, this only reproduced intermittently while doing beta upgrade tests to Firefox 8.
(Reporter)

Comment 8

6 years ago
I maybe see this problem so often because I'm using nightly builds. Seems like the image cache gets cleared when Firefox is updated?!

Comment 9

6 years ago
Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0 beta 3

This issue reproduces quite often when doing upgrades to Fx8 beta from previous beta versions (Fx4 b8, Fx5 b7 etc).

Pre: Make sure the "Show my windows and tabs from last time" option is selected for "When Firefox starts:" in Tools->Options->General.


STR:
1. Launch an older version of Firefox beta.
2. Open multiple web pages in different tabs.
3. Open Panorama.
4. Split the tabs in at least 2 different groups.
5. Open a group of tabs.
6. Update Firefox to the latest beta version.
7. After the new Firefox version is started, open Panorama.

The thumbnails for the group that was loaded when opening Fx are displayed in Panorama. Sometimes none of the thumbnails from the other groups are displayed, other times only some of them are not displayed.
Adding qa+ based on comment 9
Whiteboard: [qa+]
(Reporter)

Comment 11

5 years ago
Will be fixed by bug 744388.
Depends on: 744388
(Reporter)

Comment 12

5 years ago
Fixed by bug 744388.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

a year ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.