Last Comment Bug 658913 - Thumbnails for to-be-restored tabs are not rendered
: Thumbnails for to-be-restored tabs are not rendered
Status: RESOLVED FIXED
[qa+]
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: -- normal
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 660400 (view as bug list)
Depends on: 595601 744388
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-22 16:55 PDT by Tim Taubert [:ttaubert]
Modified: 2016-04-12 14:00 PDT (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Tim Taubert [:ttaubert] 2011-05-22 16:55:30 PDT
Since the landing of bug 595601 thumbnails for to-be-restored tabs aren't rendered anymore.
Comment 1 Tim Taubert [:ttaubert] 2011-05-22 17:08:59 PDT
Very strange. The session works in my trunk build but does not work in my up-to-date nightly. I get "Error while loading thumbnail" all the time.
Comment 2 Tim Taubert [:ttaubert] 2011-05-23 08:44:57 PDT
When opening all pages the disk cache grew up to 1.5GB and suddenly everything was lost. Seems to work now.
Comment 3 Tim Taubert [:ttaubert] 2011-05-27 05:18:24 PDT
Doesn't work for me :( We should investigate this.
Comment 4 Tim Taubert [:ttaubert] 2011-05-29 06:03:18 PDT
*** Bug 660400 has been marked as a duplicate of this bug. ***
Comment 5 Tim Taubert [:ttaubert] 2011-07-24 18:40:30 PDT
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
Comment 6 Raymond Lee [:raymondlee] 2011-10-06 02:56:56 PDT
Tim: Do you still see the issue?
Comment 7 Virgil Dicu [:virgil] [QA] 2011-10-07 08:46:56 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0

I stumbled upon this issue while doing Beta upgrades to Firefox 8 from previous Firefox versions.

I can reproduce this on all platforms when upgrading from any Firefox 4 beta to Firefox 8 beta2 with a clean profile. The thumbnails from groups are not rendered unless the respective group is loaded.

When upgrading from Firefox 5 or a newer version, this only reproduced intermittently while doing beta upgrade tests to Firefox 8.
Comment 8 Tim Taubert [:ttaubert] 2011-10-08 09:30:02 PDT
I maybe see this problem so often because I'm using nightly builds. Seems like the image cache gets cleared when Firefox is updated?!
Comment 9 Ioana (away) 2011-10-13 06:16:35 PDT
Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0 beta 3

This issue reproduces quite often when doing upgrades to Fx8 beta from previous beta versions (Fx4 b8, Fx5 b7 etc).

Pre: Make sure the "Show my windows and tabs from last time" option is selected for "When Firefox starts:" in Tools->Options->General.


STR:
1. Launch an older version of Firefox beta.
2. Open multiple web pages in different tabs.
3. Open Panorama.
4. Split the tabs in at least 2 different groups.
5. Open a group of tabs.
6. Update Firefox to the latest beta version.
7. After the new Firefox version is started, open Panorama.

The thumbnails for the group that was loaded when opening Fx are displayed in Panorama. Sometimes none of the thumbnails from the other groups are displayed, other times only some of them are not displayed.
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-10-13 08:57:01 PDT
Adding qa+ based on comment 9
Comment 11 Tim Taubert [:ttaubert] 2012-04-26 12:21:43 PDT
Will be fixed by bug 744388.
Comment 12 Tim Taubert [:ttaubert] 2012-05-02 06:50:50 PDT
Fixed by bug 744388.

Note You need to log in before you can comment on or make changes to this bug.