Text search on the page: too picky

UNCONFIRMED
Unassigned

Status

()

Firefox
General
--
minor
UNCONFIRMED
7 years ago
10 months ago

People

(Reporter: Nicolas Barbulesco, Unassigned)

Tracking

(Depends on: 1 bug)

4.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

The text search is too picky. In other browsers, it is more acceptant.

Does not find non-breaking hyphen when searching hyphen.
Does not find accented letter when searching normal letter.
Does not find normal letter when searching accented letter.
Does not find "ç" when searching "c".
Does not find "c" when searching "ç".

In my humble opinion, Firefox must find all these searches.


Reproducible: Always

Steps to Reproduce:
See in "Details".


Actual Results:  
See in "Details".


Expected Results:  
See in "Details".


Firefox 4.0.1. Windows Vista.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 640856
(Reporter)

Comment 2

7 years ago
This is not the same bug.

The other bug deals with characters which are in fact the same.

This bug deals with characters which are really different.

Updated

7 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Updated

7 years ago
Status: REOPENED → UNCONFIRMED
Ever confirmed: false

Updated

7 years ago
Version: unspecified → 4.0 Branch

Updated

10 months ago
Depends on: 640856
You need to log in before you can comment on or make changes to this bug.