Firefox Crash [@ PickChunk ]

RESOLVED INVALID

Status

()

Core
JavaScript Engine
--
critical
RESOLVED INVALID
7 years ago
4 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2014-03-01], crash signature)

(Reporter)

Description

7 years ago
Seen while reviewing trunk crash stats.  Mac and Windows crash that is fairly low volume. Some of the comments mentioned Firebug. Crashes so far: https://crash-stats.mozilla.com/report/list?signature=PickChunk

https://crash-stats.mozilla.com/report/index/ee108ff1-3bdd-4f26-a705-8f3862110520

Frame 	Module 	Signature [Expand] 	Source
0 	XUL 	PickChunk 	js/src/jsgc.cpp:470
1 	XUL 	js::gc::RefillFinalizableFreeList 	js/src/jsgc.cpp:1162
2 	XUL 	js::GlobalObject::create 	js/src/jsgcinlines.h:188
3 	XUL 	JS_NewCompartmentAndGlobalObject 	js/src/jsapi.cpp:3006
4 	XUL 	CreateNewCompartment 	js/src/xpconnect/src/nsXPConnect.cpp:1018
5 	XUL 	xpc_CreateGlobalObject 	js/src/xpconnect/src/nsXPConnect.cpp:1055
6 	XUL 	nsXPConnect::InitClassesWithNewWrappedGlobal 	js/src/xpconnect/src/nsXPConnect.cpp:1143
7 	XUL 	nsJSContext::CreateNativeGlobalForInner 	dom/base/nsJSEnvironment.cpp:2243
8 	XUL 	nsGlobalWindow::SetNewDocument 	dom/base/nsGlobalWindow.cpp:2021
9 	XUL 	DocumentViewerImpl::InitInternal 	layout/base/nsDocumentViewer.cpp:980
10 	XUL 	DocumentViewerImpl::Init 	layout/base/nsDocumentViewer.cpp:726
11 	XUL 	nsDocShell::SetupNewViewer 	docshell/base/nsDocShell.cpp:7698
12 	XUL 	nsDocShell::Embed 	docshell/base/nsDocShell.cpp:5746
13 	XUL 	nsDocShell::CreateAboutBlankContentViewer 	docshell/base/nsDocShell.cpp:6523
14 	XUL 	nsDocShell::EnsureContentViewer 	docshell/base/nsDocShell.cpp:6427
15 	XUL 	nsDocShell::GetInterface 	docshell/base/nsDocShell.cpp:892
16 	XUL 	nsGetInterface::operator 	obj-firefox/x86_64/xpcom/build/nsIInterfaceRequestorUtils.cpp:52
17 	XUL 	nsCOMPtr_base::assign_from_helper 	obj-firefox/x86_64/xpcom/build/nsCOMPtr.cpp:150
18 	XUL 	nsGlobalWindow::GetDocument 	
19 	XUL 	nsWindowSH::PreCreate 	
20 	XUL 	ConstructProxyObject 	js/src/xpconnect/src/xpcwrappednative.cpp:3940
21 	XUL 	XPCConvert::NativeInterface2JSObject 	js/src/xpconnect/src/xpcconvert.cpp:1190
22 	XUL 	XPCConvert::NativeData2JS 	js/src/xpconnect/src/xpcconvert.cpp:485
23 	XUL 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcprivate.h:3203
24 	XUL 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1610
25 	XUL 	js::mjit::stubs::UncachedCallHelper 	js/src/jscntxtinlines.h:277
26 	XUL 	js::mjit::stubs::UncachedCall 	js/src/methodjit/InvokeHelpers.cpp:417
27 		@0x127f9f5fd 	
28 	XUL 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:685
29 	XUL 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:715
30 	XUL 	js::RunScript 	js/src/jsinterp.cpp:600
31 	XUL 	js::Invoke 	js/src/jsinterp.cpp:684
32 	XUL 	js::ExternalInvoke 	js/src/jsinterp.cpp:806
33 	XUL 	js::ExternalGetOrSet 	js/src/jsinterp.cpp:846
34 	XUL 	js_GetPropertyHelper 	js/src/jsscopeinlines.h:269
35 	XUL 	InlineGetProp 	js/src/methodjit/StubCalls.cpp:1877
36 	XUL 	js::mjit::stubs::GetProp 	js/src/methodjit/StubCalls.cpp:1895
37 		@0x127a68ea1 	
38 	XUL 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:685
39 	XUL 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:715
40 	XUL 	js::RunScript 	js/src/jsinterp.cpp:600
41 	XUL 	js::Invoke 	js/src/jsinterp.cpp:684
42 	XUL 	js::ExternalInvoke 	js/src/jsinterp.cpp:806
43 	XUL 	js::ExternalGetOrSet 	js/src/jsinterp.cpp:846
44 	XUL 	js_GetPropertyHelper 	js/src/jsscopeinlines.h:269
45 	XUL 	InlineGetProp 	js/src/methodjit/StubCalls.cpp:1877
46 	XUL 	js::mjit::stubs::GetProp 	js/src/methodjit/StubCalls.cpp:1895
47 		@0x127a6c883 	
48 	XUL 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:685
49 	XUL 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:715
50 	XUL 	js::RunScript 	js/src/jsinterp.cpp:600
51 	XUL 	js::Invoke 	js/src/jsinterp.cpp:684
52 	XUL 	js::ExternalInvoke 	js/src/jsinterp.cpp:806
53 	XUL 	JS_CallFunctionValue 	js/src/jsapi.cpp:5081
54 	XUL 	nsXBLProtoImplAnonymousMethod::Execute 	content/xbl/src/nsXBLProtoImplMethod.cpp:337
55 	XUL 	nsBindingManager::ProcessAttachedQueue 	content/xbl/src/nsBindingManager.cpp:1028
56 	XUL 	nsBindingManager::EndOutermostUpdate 	content/xbl/src/nsBindingManager.cpp:1782
57 	XUL 	nsDocument::EndUpdate 	content/base/src/nsDocument.cpp:3943
58 	XUL 	nsXULDocument::EndUpdate 	content/xul/document/src/nsXULDocument.cpp:3338
59 	XUL 	nsINode::ReplaceOrInsertBefore 	content/base/src/mozAutoDocUpdate.h:66
60 	XUL 	nsIDOMNode_AppendChild 	nsINode.h:1267
61 	XUL 	js::mjit::stubs::UncachedCallHelper 	js/src/jscntxtinlines.h:277
62 	XUL 	js::mjit::stubs::UncachedCall 	js/src/methodjit/InvokeHelpers.cpp:417
63 		@0x12e376988 	
64 	XUL 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:685
65 	XUL 	js::mjit::JaegerShotAtSafePoint 	js/src/methodjit/MethodJIT.cpp:715
66 	XUL 	js::Interpret 	js/src/jsinterp.cpp:6335
67 	XUL 	js::RunScript 	js/src/jsinterp.cpp:603
68 	XUL 	js::Invoke 	js/src/jsinterp.cpp:684
69 	XUL 	js::ExternalInvoke 	js/src/jsinterp.cpp:806
70 	XUL 	JS_CallFunctionValue 	js/src/jsapi.cpp:5081
71 	XUL 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1662
72 	XUL 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:586
73 	XUL 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_x86_64_darwin.cpp:153
74 	XUL 	XUL@0xe550ea 	
75 	XUL 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_unix.cpp:172
76 	XUL 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_unix.cpp:195
77 	XUL 	XPCConvert::JSData2Native 	js/src/xpconnect/src/xpcconvert.cpp:1100
78 	XUL 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3144
79 	XUL 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1610
80 	XUL 	js::Interpret 	js/src/jscntxtinlines.h:277
81 	XUL 	js::RunScript 	js/src/jsinterp.cpp:603
82 	XUL 	js::Invoke 	js/src/jsinterp.cpp:684
83 	XUL 	js::ExternalInvoke 	js/src/jsinterp.cpp:806
84 	XUL 	JS_CallFunctionValue 	js/src/jsapi.cpp:5081
85 	XUL 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1903
86 	XUL 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:9128
87 	XUL 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9473
88 	XUL 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:424
89 	XUL 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:520
90 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:618
91 	XUL 	NS_ProcessPendingEvents_P 	obj-firefox/x86_64/xpcom/build/nsThreadUtils.cpp:200
92 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/src/xpwidgets/nsBaseAppShell.cpp:130
93 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:422
94 	CoreFoundation 	__CFRunLoopDoSources0 	
95 	CoreFoundation 	__CFRunLoopRun 	
96 	CoreFoundation 	CFRunLoopRunSpecific 	
97 	HIToolbox 	HIToolbox@0x2e7ed 	
98 	HIToolbox 	HIToolbox@0x2e550 	
99 	HIToolbox 	HIToolbox@0x2e4ab 	
100 	AppKit 	_DPSNextEvent 	
101 	AppKit 	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	
102 	AppKit 	-[NSApplication run] 	
103 	XUL 	nsAppShell::Run 	widget/src/cocoa/nsAppShell.mm:769
104 	XUL 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:224
105 	XUL 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3698
106 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:159
107 	firefox-bin 	firefox-bin@0x953

Comment 1

7 years ago
Looks like a lot of those are dupes, and there's at least one reports that says it crashes with Firebug and doesn't when Firebug is disabled.
Crash Signature: [@ PickChunk ]
I can confirm experiencing the bug with Firebug 1.7.1 and 1.7.3. Disabling it prevents the crash.

I first experienced the crash around 2011-06-22 though both the 20110622 and 20110621 nightlies crash with the current profile. Perhaps I made some change to the profile that caused it (I don't think it was an extension upgrade).
Can you experience the crash with Firebug 1.9a3?
http://getfirebug.com/releases/firebug/1.9/firebug-1.9.0a3.xpi

Note that Firebug is broken on current nightlies since 09/23/2011, see bug 689101

Honza

Comment 4

4 years ago
(In reply to Ori Avtalion (salty-horse) from comment #2)
> I can confirm experiencing the bug with Firebug 1.7.1 and 1.7.3. Disabling
> it prevents the crash.
> 
> I first experienced the crash around 2011-06-22 though both the 20110622 and
> 20110621 nightlies crash with the current profile. Perhaps I made some
> change to the profile that caused it (I don't think it was an extension
> upgrade).

Ori, can you still reproduce?
Stacks I see for current versions don't match this bug
Stacks
Flags: needinfo?(ori)
Whiteboard: [closeme 2014-03-01]
I don't crash with Nightly & latest Firebug for a long time.

I tried installing Firebug 1.7.1 on Firefox 26.0 just to test this, and the versions are not compatible.

I'm closing this bug. :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ori)
Resolution: --- → INVALID
FWIW the current stable version of Firebug is 1.12.6 and the current Firefox version is 27.0.1.
Though I also didn't see that crash for a long time.

Sebastian
You need to log in before you can comment on or make changes to this bug.