Satisfy the browse use-case through the search interface

VERIFIED FIXED in Builder 0.9.6

Status

addons.mozilla.org Graveyard
Add-on Builder
P2
normal
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: dbuc, Assigned: seanmonstar)

Tracking

unspecified
Builder 0.9.6
Dependency tree / graph

Details

(Reporter)

Description

7 years ago
We should make it possible to browser using the search interface when a search term is not specified. This will enable us to use the search page for displaying extended results to the user when they click the "More Add-ons/Libraries" links on front page.

Our browse implementation should enable a user-flow much like Amazon's. On Amazon you can pick a top-level section and add facets without entering a search term, and it shows you all matching items that fit those constraints.

Here is an example query from Amazon, Computer section with a price range and screen size specified: http://amzn.to/lnZ4hc
(Reporter)

Updated

7 years ago
Severity: normal → major
Priority: -- → P2
Target Milestone: --- → Builder 0.9.6
Assignee: nobody → dd
Priority: P2 → P1
Blocks: 659062
I think this is something that can be done by anybody once bug 656394 is finished.

I wrote a lot of library code that should make this fairly easy for Sean (or anybody) to pickup.
Assignee: dd → nobody
Depends on: 656394
No longer blocks: 659062
Depends on: 659062
(Reporter)

Updated

7 years ago
Assignee: nobody → smcarthur
(Reporter)

Updated

7 years ago
Severity: major → normal
Priority: P1 → P2
(Reporter)

Updated

7 years ago
Duplicate of this bug: 659062
(Assignee)

Comment 3

7 years ago
bonk. https://github.com/mozilla/FlightDeck/commit/c692e6664eca0f193adfe9e9c31f60951366b80f
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified FIXED (implemented); there have been smaller, spinoff bugs filed, too.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.