If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sending event invitations via zimbra sends unusable emails

RESOLVED DUPLICATE of bug 519279

Status

Infrastructure & Operations
Servicedesk
RESOLVED DUPLICATE of bug 519279
6 years ago
3 years ago

People

(Reporter: Benjamin Smedberg, Assigned: justdave)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
When legneato and damon send event invitations using the zimbra webapp, the meeting invitees get an email like this:

* multipart/alternative
** text/plain - meeting description only
** text/html - meeting description only
** text/calendar

Most email clients which are not the zimbra webapp or thunderbird with lightning display the text/html version of the email. This is useless, because it doesn't show you the date or time of the invitation. This has bitten me multiple times in the past week.

Updated

6 years ago
Assignee: server-ops → desktop-support
Component: Server Operations → Server Operations: Desktop Issues
What client are you using?
Component: Server Operations: Desktop Issues → Server Operations
(Reporter)

Comment 2

6 years ago
Do you mean which client is legneato using for the calendar, or the email client I'm using to receive the mail?

Comment 3

6 years ago
"yes"

IIRC, you forward your @mozilla.com email outside of Zimbra.  The suspicion is that the forwarded invites are getting botched but trying to figure it out.

I can't duplicate this with the web UI or with Mail.app (or iCal) and no one external to Mozilla that I work with has calendaring issues .
(Reporter)

Comment 4

6 years ago
Yeah, I'm using tbird (without lightning) because I primarily use google calendar. Are you saying that if I didn't forward (but just configured tbird to load email directly from mozilla.com) that I'd get a different email which was more readable?

Comment 5

6 years ago
I think so.  You could turn off forwarding and test?  Desktop will try to test too.

Comment 6

6 years ago
I used iCal to create it, then edited it with zimbra's webui hoping that would produce a more useful edit email.

Comment 7

6 years ago
yeah, that's how I often do it too.

Updated

6 years ago
Component: Server Operations → Server Operations: Desktop Issues
(Reporter)

Comment 8

6 years ago
Created attachment 542473 [details]
Broken email

After turning mail forwarding off, I got another one of these emails with an unreadable body. Rob Campbell sent it using iCal. Is this just an iCal bug, then, which cannot be fixed? The X-Mailer header is confusing:

X-Mailer: Zimbra 6.0.8_GA_2661 (DAVKit/4.0.3 (732.2); CalendarStore/4.0.4 (997.7); iCal/4.0.4 (1395.7); Mac OS X/10.6.7 (10J869))

Comment 9

6 years ago
Since turning forwarding off, is this the only issue you have when people send you mail and is  this the only problem you have on ical and not zimbra?
Assignee: desktop-support → shui
(Reporter)

Comment 10

6 years ago
This is the problem I've always had, turning forwarding off hasn't helped. I don't really know whether it's also a problem with the zimbra webapp, although I've had some emails that were better (e.g. the HTML body had things like the time and date).

Comment 11

6 years ago
Same thing just happened with an invite I sent to bz...
And to be clear my setup is that I'm using Thunderbird directly to connect to the IMAP server on mail.mozilla.com.  No forwarding.

I'm sorry I didn't save the exact message I received, but the symptoms were exactly as described in comment 0.
Spencer, any updates?

Updated

6 years ago
QA Contact: mrz → tfairfield

Updated

6 years ago
Assignee: shui → hlangi
Dave, in training, can you ask about this one?
Assignee: hlangi → justdave
Ping?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 519279
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.