Surprise test failure in test_bookmark_engine.js, test_corrupt_keys.js

RESOLVED FIXED in mozilla6

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: rnewman, Assigned: philikon)

Tracking

unspecified
mozilla6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

7 years ago
"constraint failed" when changing GUID, line 55. Looks like our 'random' GUID is no longer acceptable!
(Reporter)

Comment 1

7 years ago
Created attachment 534549 [details] [diff] [review]
Proposed patch. v1
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Attachment #534549 - Flags: review?(philipp)
(Assignee)

Updated

7 years ago
Attachment #534549 - Flags: review?(philipp) → review+
(Reporter)

Comment 2

7 years ago
Part two is a lack of HMAC failures in test_corrupt_keys, presumably because our lastSync isn't starting afresh at 0...
(Reporter)

Updated

7 years ago
Summary: Surprise test failure in test_bookmark_engine.js. → Surprise test failure in test_bookmark_engine.js, test_corrupt_keys.js
(Reporter)

Comment 3

7 years ago
Created attachment 534562 [details] [diff] [review]
Part 2. v1

Fix this in two places: firstly by refreshing a single server item, and secondly by just setting lastSync to 0. That matches up with the intent of the test.
Attachment #534562 - Flags: review?(philipp)
Created attachment 534579 [details] [diff] [review]
fix root cause in test harness
Assignee: rnewman → philipp
Attachment #534549 - Attachment is obsolete: true
Attachment #534562 - Attachment is obsolete: true
Attachment #534562 - Flags: review?(philipp)
Attachment #534579 - Flags: review?(rnewman)
Comment on attachment 534579 [details] [diff] [review]
fix root cause in test harness

I should explain this: basically, since we call do_get_profile(), we already have a ProfD directory, we don't need to provide one. If we do and we map it to cwd, it will get shared between test runs and non-clobber builds will have test failures.
(Reporter)

Comment 6

7 years ago
Comment on attachment 534579 [details] [diff] [review]
fix root cause in test harness

Two consecutive all-pass test runs. Looks good.
Attachment #534579 - Flags: review?(rnewman) → review+
http://hg.mozilla.org/mozilla-central/rev/36e0a6facb40
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in services][qa-] → [qa-]
Target Milestone: --- → mozilla6
You need to log in before you can comment on or make changes to this bug.