Closed Bug 659119 Opened 10 years ago Closed 4 years ago

Youtube doesn't work (not showing/slow/lagging/hogging CPU/unresponsive/controls don't work)

Categories

(Core :: Plug-ins, defect, P3)

5 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
platform-rel --- ?
firefox5 + ---

People

(Reporter: cww, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [platform-rel-Youtube] [input] blocked, no reliable STR... may be specific to some graphics configurations)

We're seeing a fair amount of feedback around youtube not working or being slow or lagging or unresponsive or using lots of CPU.

http://input.mozilla.com/en-US/opinion/2067792
http://input.mozilla.com/en-US/opinion/2066463
http://input.mozilla.com/en-US/opinion/2066345
http://input.mozilla.com/en-US/opinion/2065971

for example.

This bug is being filed as part of an effort to get top feedback from input into bugzilla.
This is from Firefox 5 beta.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
I wonder if its bug 651100.
Blocks: slowui
Adding feedback items from input to tracking so we can make sure that they don't get missed.
We have a *ton* of plugin hang problems in 5.0 right now - most of them not new, but risen significantly in volume compared to e.g. 4.0[.1], see https://crash-stats.mozilla.com/topcrasher/byversion/Firefox/5.0/7/plugin
What I forgot to mention in this comment is that "hang" just means we didn't get a timely response from the plugin and killed it. Because of that, those hangs and the reaction noted here are very probably related in some way.
Have we made any effort to reproduce this internally?
(In reply to comment #6)
> Have we made any effort to reproduce this internally?

I haven't heard of any yet, but given what we're seeing here, I think we should try to get someone from QA look into that.
Keywords: qawanted
Now that we've shipped, some more clues that may help repro:

It seems to happen in some subset of the following cases: 
* when using popup browser
* when watching multiple videos in a row (maybe memory usage dependent)
* when watching WebM
* when fullscreen
* perf related (laggy, stutters, stops halfway, may need older hardware to test)
Depends on: 720000
This may or may not be unrelated. For some time (not too long after the new Mozilla version numbering changes), I have been experiencing issues with Youtube and some other Flash video players.

Once streaming and playing video, it seems to be fine, but when using the Flash-based UI for controlling the video, it stalls horribly and the flash plugin container process CPU usage goes up by 100 to 300% of the usage when simply streaming video without user interaction.

When using the UI and becoming tired of waiting and trying to close or change tab, Firefox seems to be hanging, waiting for the flash plugin to respond before doing anything else.

This is on Windows 7 x86_64 with Firefox 16.0.
Looks to work as expected on Latest Nightly (2013/01/11) on Windows 7 x64 and Mac OS 10.8. No slow, lag or hogg found while testing different URL's from youtube.

I've tested this issue using new profile and default too, with and without HTML5 enabled.
Priority: -- → P3
Whiteboard: [input] → [input] blocked, no reliable STR... may be specific to some graphics configurations
I verified on Ubuntu x86 and it also works as expected.
Old bug, removing qawanted based on comments 10, 11.
Keywords: qawanted
I always get this even on the latest 21 release, I only watch youtube videos using HTML5 and don't have flash installed, I click on play the video and pause to wait for buffering and then click play again and the video plays but them the player or firefox becomes unresponsive for more than 5 seconds, the video continues to play with the audio but the image is still, when this occurs the light of the hard drive access of my laptop goes up non stop only switching off after the video becomes responsive again.
Unable to reproduce comment 13 on FF 21, youtube html5 mode, Win 7 x64. Everything looks ok.
It doesn't happen on all videos, my system is ubuntu 12.04 x64 with FullHD display, an intel HD 3000 graphics controller and 4gb RAM, also google+ scrolling is slow.
Not able to reproduce this issue as mentioned in Comment 10 on Ubuntu 13.04 x86 using Latest Nightly 24:

Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20130526 Firefox/24.0
20130526031046

I am using Intel HD 4000 graphics.
I am pretty sure this bug is not reproducible on a fast storage like an SSD, as the slowdown stops when the light of the HDD goes out, this video under webm for example gave me the slowdown I described https://www.youtube.com/watch?v=on4DRTUvst0&feature=youtu.be
A better way to reproduce the bug on my system is to use heavy disk operations or/and heavy downloads speed.
(In reply to Biodark from comment #18)
> A better way to reproduce the bug on my system is to use heavy disk
> operations or/and heavy downloads speed.
Still cannot reproduce while copying 10 GB of files on my hdd (which is not SSD).
Perhaps there is something wrong with your hdd. You could try a defragmentation if you have a lot of data on it.
(In reply to Paul Silaghi [QA] from comment #19)
> Still cannot reproduce while copying 10 GB of files on my hdd

Probably it's not plugins related. I don't think we need to track this bug explicitly in bugzilla. I think it can be closed.
platform-rel: --- → ?
Whiteboard: [input] blocked, no reliable STR... may be specific to some graphics configurations → [platform-rel-Youtube] [input] blocked, no reliable STR... may be specific to some graphics configurations
Anyone still see this?

Been using youtube a lot lately. WFM using current nightly on win7.
Flags: needinfo?(810d4rk)
Whiteboard: [platform-rel-Youtube] [input] blocked, no reliable STR... may be specific to some graphics configurations → [closeme 2017-02-01][platform-rel-Youtube] [input] blocked, no reliable STR... may be specific to some graphics configurations
I'm going to resolve this since this was filed against Flash-based youtube which is no longer relevant.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(810d4rk)
Whiteboard: [closeme 2017-02-01][platform-rel-Youtube] [input] blocked, no reliable STR... may be specific to some graphics configurations → [platform-rel-Youtube] [input] blocked, no reliable STR... may be specific to some graphics configurations
You need to log in before you can comment on or make changes to this bug.