Dragging links to other programs results in url + link text

VERIFIED DUPLICATE of bug 44371

Status

()

Core
Drag and Drop
VERIFIED DUPLICATE of bug 44371
17 years ago
17 years ago

People

(Reporter: Damian Christey, Assigned: Blake Ross)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This has been happening for quite some time, and I can't find a bug on it,
though it has been noted in other DND bugs.

Dragging a link from Mozilla to a program that accepts drag and drop urls,
specificly GNOME programs, results in that program receiving a url that contains
the link text in addition to the actual url.

To reproduce:
1. Drag a link from Mozilla, say the "prefs" link at the bottom of this bugzilla
page, to the GNOME desktop.
2. An icon is created on the desktop, with a text label of
"http://bugzilla.mozilla.org/userprefs.cgi prefs".  Viewing the properties will
reveal that this is the url it points to as well.  The "prefs" should not be in
there.
3. Try double clicking on the link on the desktop.  It will open a browser
window with the url "http://bugzilla.mozilla.org/userprefs.cgiprefs", which is,
of course, not found.

This behavior occurs in any program you can drag urls to, such as the "GTM" and
"Downloader for X" download managers.
QA Contact: sairuh → tpreston

Comment 1

17 years ago
When I drag a link to the gnome-terminal, I get *only* the text of the link, and
not the URL.

Also, this may be a dupe of bug 62022 and 63418

Comment 2

17 years ago
-> drag-and-drop component
Assignee: ben → blakeross
Component: XP Apps: GUI Features → XP Apps: Drag and Drop

Comment 3

17 years ago
I think the cause of this is the same as for bug 44371.
Since this involves dragging into an outside app, not into one of ours,
I'll just make this dependent.
Depends on: 44371

Updated

17 years ago
No longer depends on: 44371

Comment 4

17 years ago


*** This bug has been marked as a duplicate of 44371 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.