insertion mark in text boxes sometimes is misaligned

VERIFIED DUPLICATE of bug 61658

Status

()

VERIFIED DUPLICATE of bug 61658
18 years ago
18 years ago

People

(Reporter: joe, Assigned: rods)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-2mdk i586; en-US; m18) Gecko/20010118
BuildID:    2001011821

If the insertion mark is moved between lines in such a way that
it ends up at the end of the line it is moved to, the mark
becomes misaligned with the text.

Reproducible: Always
Steps to Reproduce:
Go into a text box like "Steps to Reproduce"
Enter in three lines of text
Make sure that the third line is longer than the previous two
When you are done press up arrow.
Notice that the insertion mark is not longer aligned with the 
base line of the previous line.


Actual Results:  The insertion mark is no longer aligned with the text line.

Expected Results:  The insertion mark should be aligned with the text

Seems to have appearred just now.  Didn't see this in previous builds.

Comment 1

18 years ago
Actually, this has been around for a while.  (A while being at least a week or two.)

You can reproduce this by simply typing a line of text in a textbox, hitting the
Home key and then hitting the End key.  The probem is related to moving up or
down, it's related to moving to the end of a line in any fashion other than
typing - even using the mouse to position the cursor at the end of a line does it.

Comment 2

18 years ago
This has been around since October or before. By my logic, it must be a dupe,
but I can't find it. It should go over to XP Toolkit, and summary should mention
"textarea".

Suggest summary to be: "In textarea, cursor misaligned when not using left or
right to move to end of line", although that's a bit long so if someone could
condense it a little?

I don't have privileges to do so, though, so I'll leave that to someone else.

Note that this happens only for *hard* LFs, not word-wrap line breaks, and only
when there is some text on the line already.

If you use left-arrow to back up to the previous line, this will happen, too.

The mispositioning is up by two pixels on my linux 2000112406 build.

Comment 3

18 years ago
this is most probably a duplicate of bug 61658

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 61658 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Verifying dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.