Custom tabs in addon manager can not be opened now

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Yakove, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110524 Firefox/6.0a1
Build Identifier: 

Custom tabs, such as User styles (created by Stylish addon) or User scripts (Greasemonkey) do not respond when clicking on it. It's a regression since few last builds

Reproducible: Always

Steps to Reproduce:
1. Create new profile
2. Go to https://arantius.com/misc/gm-nightly/ and setup latest dev build of Greasemonkey (compatible with FF6), restart browser
3. Go to userscripts.org and install one or more scripts
4. Now go to addon manager. There's a new item - User Scripts
5. Click on this item

Actual Results:  
Nothing happens

Expected Results:  
Should open a tab with the list of installed userscripts
Do you see any failures in the error console? Also can you please check the builds from the last days which introduced this regression? The changeset ids from about:buildconfig would be kinda helpful.
Keywords: regression, regressionwindow-wanted
Sounds like that add-on needs to be updated from changes in bug 595848.

I wasn't expecting that on having any breaking effect on add-ons though, are there any messages in the error console?
Component: Add-ons Manager → Extension Compatibility
Keywords: regression, regressionwindow-wanted
Product: Toolkit → Firefox
QA Contact: add-ons.manager → extension.compatibility
(Reporter)

Comment 3

7 years ago
In error console errors like that:

Error: aAddon is null
Source File: chrome://greasemonkey/content/addons4-overlay.js
Line: 78
As Dave mentioned could be the reason of landing bug 595848. I would like to track all those regression from it, so I will add the dependency.
Blocks: 595848
Keywords: regression

Comment 5

7 years ago
Tracked down with GNU/Linux:

Last good nightly: 2011-05-20 First bad nightly: 2011-05-21

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2e0e36b0feae&tochange=21c304c5f351


The first bad revision is:
changeset:   69794:7d17e8e3c617
user:        Dave Townsend <dtownsend@oxymoronical.com>
date:        Fri May 20 10:36:28 2011 -0700
summary:     Bug 595848: Dynamically generate the list of categories. r=Unfocused
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk
Yes, there are a few requirements for add-ons doing this sort of thing. I should have some docs with the details on it done sometime tomorrow.
The blog post is up now: http://www.oxymoronical.com/blog/2011/05/Creating-custom-add-on-types-just-got-easier

For greasemonkey the specific issue is that they must now register their new add-on type. They should be able to do this without breaking backwards compatibility.

Comment 8

7 years ago
Reporter, do you have anything new about this issue?
(Reporter)

Comment 9

7 years ago
Now we have fixed versions of Stylish and Scriptish, waiting for Greasemonkey.

This is not Firefox issue, maybe WONTFIX

Comment 10

7 years ago
Considering comment9, can you please change the status to Resolved Invalid.
thx
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 11

7 years ago
(In reply to comment #9)
> Now we have fixed versions of Stylish and Scriptish, waiting for
> Greasemonkey.
> 
> This is not Firefox issue, maybe WONTFIX

Can you direct me to new scriptish ver? Can't find it at moz-addons nor github
(Reporter)

Comment 12

7 years ago
(In reply to comment #11)

> Can you direct me to new scriptish ver? Can't find it at moz-addons nor
> github

https://github.com/downloads/erikvold/scriptish/scriptish-0.1.1.xpi

Comment 13

7 years ago
Thanks Yakove.

Update on Greasemonkey: v0.9.6 was released yesterday and claims to have fixed the bug for FF5.0. I can't verify because I run Aurora (6.0a2) and Nightly on which the addon still malfunctions; Scriptish on the other hand is compatible with all versions.

Again, this is just an update on the Greasemonkey team's progress.
You need to log in before you can comment on or make changes to this bug.