AMO should detect equivalent (but not identical) version strings

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Developer Pages
P4
minor
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: jorgev, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 534879 [details]
Version check response from AMO showing the update

Steps to reproduce:
1) Go to the ImTranslator page on AMO (https://addons.mozilla.org/en-US/firefox/addon/imtranslator/)
2) Go to the All Versions page and install version 4.01 (this is the next-to-last approved version).
3) After restarting, check for updates in the Add-ons Manager.

Observed result:
No updates available.

Expected result:
Show an update available to version 4.1.

I'm attaching the response from AMO, which appears to be correct.

I was able to reproduce on the latest 3.6 and 4.0 stable versions.

Comment 1

7 years ago
Not a bug.

The previous version is 4.01, which is the same as 4.1, hence no update is offered.
(Numbers will be compared as actual numbers, not as strings, hence "01" is |1|)

Comment 2

7 years ago
... You may count this as an AMO bug, however. AMO should have caught that it's the same version.
(Reporter)

Comment 3

7 years ago
Moving over to AMO.

We should detect this on submission. The rules are here: https://developer.mozilla.org/en/Toolkit_version_format
We should either reject, or warn the user that the uploaded file matches an already existing version.
Component: Add-ons Manager → Developer Pages
Product: Toolkit → addons.mozilla.org
QA Contact: add-ons.manager → developers
Summary: Add-on Manager fails to update ImTranslator from AMO → AMO should detect equivalent (but not identical) version strings
Version: Trunk → unspecified
AMO version formatting is a little more restrictive than the page in comment 3 describes, but that concept is right.  Look at actual AMO code for the differences (cap on length, and restriction of allowed characters, iirc)

Comment 5

7 years ago
Created attachment 535020 [details]
toolkitversion.py, Python toolkit version parsing and comparison

My toolkit version parser, normalizer (and comparisons), according to Toolkit version format and the actual toolkit comparator[1]
Might be helpful here...

E.g.
>>> from toolkitversion import ToolkitVersion
>>> print ToolkitVersion(1.0) == ToolkitVersion("1.0.0.0.0.")
True
>>> print ToolkitVersion(1.0)
1
>>> print ToolkitVersion("1.0.0.0.0.")
1
>>> print ToolkitVersion("1.0664..b1.000010b3pre")
1.664.0.0b1.10b3pre
>>> print ToolkitVersion("1.b01build019")
1.0b1build019

[1] http://mxr.mozilla.org/mozilla-central/source/xpcom/glue/nsVersionComparator.cpp
(Reporter)

Updated

7 years ago
Severity: normal → minor
Priority: -- → P4
Target Milestone: --- → 4.x (triaged)
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.