Mozmill doesn't shutdown Firefox on OS X if a modal dialog is open

RESOLVED DUPLICATE of bug 794020

Status

defect
--
critical
RESOLVED DUPLICATE of bug 794020
8 years ago
6 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

As what we have seen recently on allizom.mozilla.org, is that Mozrunner cannot shutdown restart tests correctly if a modal dialog (i.e. invalid certificate) is open and stops the test from running. This is only an issue on OS X but works fine on Windows and Linux.

As discussed in the meeting Clint thinks he knows why that happens. He probably has it fixed for the mozprocess changes for mozmill 2.0, so an easy fix would be possible.
Clint, would you need a testcase?
(In reply to comment #1)
> Clint, would you need a testcase?

I LOVE testcases! They are yummy! \o/  

In other words, yes, always.
Posted patch Testcase (obsolete) — Splinter Review
The testcase from bug 615662 is mostly valid. I only had to minor update it a bit. Please make sure that you have a slower network connection when running it.

Steps:
1. Clone the mozmill-tests repository
2. Switch to the mozilla-1.9.2 branch
3. Apply the patch
4. Run Namoroka with tests/functional/restartTests/testExtensionInstallUninstall.js

At the end of test1.js an unexpected modal dialog appears when the application gets closed. It seems to block the complete shutdown and also Mozmill doesn't kill the process.
Severity: major → critical
Keywords: hang
bumping whiteboard following 1.5.4 release
Whiteboard: [mozmill-1.5.4?] → [mozmill-1.5.5?]
Same happened today on our Windows boxes due to incompatibilities with the 9.0a1 builds. Mozmill 1.5.4b7 is only compatible up to 8.0a1 and caused the same hang for us for the update tests from 8.0a1 to 9.0a1.
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [mozmill-1.5.5?] → [mozmill-1.5.6?]
So how should we handle this bug? Anything we can/want to fix on 1.5.x? It's one of the main reasons why we have to move forward to be mozmill 2.0 compatible.
Whiteboard: [mozmill-1.5.6?] → [mozmill-1.5.9?]
Whiteboard: [mozmill-1.5.9?] → [mozmill-1.5.10?]
We don't want to fix this for 1.5.x but we have to check it in 2.0
Assignee: ctalbert → nobody
Whiteboard: [mozmill-1.5.10?] → [mozmill-1.5.10-]
Whiteboard: [mozmill-1.5.10-] → [mozmill-1.5.10-][mozmill-2.0?]
Posted patch Testcase v2Splinter Review
Attachment #535832 - Attachment is obsolete: true
It appears to be fixed in 2.0. I have also updated the test case.
Also, the hang is still present but Firefox will close from timing out.
Sounds good David. Would you mind to port this test so it is using the code from the API refactoring project? I kinda would like to know how our default modal dialog handler, which runs all the time in the background, will handle that situation. The repository you can find here: https://github.com/whimboo/mozmill-api-refactor

If the dialog is caught and we continue the test-run but showing a failure we are fine to close this bug out.

I'm setting this as a blocker for now, because that's really the most annoying thing we currently experience with Mozmill 1.5.x and which early abort a test-run.
Whiteboard: [mozmill-1.5.10-][mozmill-2.0?] → [mozmill-1.5.10-][mozmill-2.0+]
I tried that patch with Mozmill 1.5 but was never able to hit this condition. Given those results the updated test doesn't really seem to be useful. I will close the bug for now but whenever we experience the problem again, we should reopen. Looks like we are ok for now.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
It's still visible and it depends on bug 794020.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: [mozmill-1.5.10-][mozmill-2.0+] → [mozmill-1.5.10-][mozmill-2.1?]
Bug 794020 has more information on it and I'm going to fix that problem over there.
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [mozmill-1.5.10-][mozmill-2.1?]
Duplicate of bug: 794020
You need to log in before you can comment on or make changes to this bug.