Alter Ace's jslint to not error on Mozilla-specific JavaScript syntax

RESOLVED FIXED in Builder 1.0

Status

addons.mozilla.org Graveyard
Add-on Builder
P2
normal
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: seanmonstar, Assigned: dbuc)

Tracking

unspecified
Builder 1.0

Details

(Reporter)

Description

7 years ago
Ace runs a jslint/jshint script on the code in the editor, and puts up warnings on lines that don't pass. Unfortunately, it finds things like "const", "let", destructuring assignment, list comprehensions, etc.

If we can't get it to not show warnings/errors for this syntax that is valid, perhaps we should turn it off until there is an analyzer that can work with it.
(Reporter)

Updated

7 years ago
Priority: -- → P2
Target Milestone: --- → Builder 0.9.6
(Assignee)

Updated

7 years ago
Assignee: nobody → dbuchner
(Assignee)

Updated

7 years ago
Target Milestone: Builder 0.9.6 → Builder 0.9.7
(Reporter)

Updated

7 years ago
Blocks: 665500
(Assignee)

Updated

7 years ago
Target Milestone: Builder 0.9.7 → Builder 0.9.8
(Assignee)

Comment 1

7 years ago
The guys from jsHint are on this, moving to the next milestone until I hear word that it is done.
Target Milestone: Builder 0.9.8 → Builder 0.9.9
(Assignee)

Updated

7 years ago
Duplicate of this bug: 665500
(Assignee)

Updated

7 years ago
Target Milestone: Builder 0.9.9 → Builder 0.9.12
(Assignee)

Updated

7 years ago
Target Milestone: Builder 0.9.12 → Builder 1.0
(Assignee)

Comment 3

7 years ago
This is now fixed in the live version of ACE.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 4

7 years ago
Has anybody retained a code sample that was failing?
(Reporter)

Comment 5

7 years ago
Example keywords that errored: const, or let...

Comment 6

7 years ago
I tried those and couldn't replicate it - I was expecting something more complicated!

This is verified fixed then.
(Assignee)

Comment 7

7 years ago
The more recent versions of ACE to correctly identify these keywords, we should upgrade soon.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.