If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot submit forms sometimes

NEW
Unassigned

Status

Fennec Graveyard
General
6 years ago
6 years ago

People

(Reporter: microrffr, Unassigned)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Android; Linux armv7l rv:6.0a1) Gecko/20110524 Firefox/6.0a1 Fennec/6.0a1

Sometimes you can't submit forms (submit buttons won't work; VKB return doesn't submit either).
I'm not completely sure about this, but I think it happens after Fennec runs out of memory.
Actually, I'm not sure if it's running out of memory, but it's the thing where the awesome bar will suddenly appear and all the tabs other than the active one get unloaded.

Reproducible: Sometimes

Steps to Reproduce:
1. Visit http://www.google.com/m and make sure you can submit a search.
2. Open a lot of tabs until the awesome bar appears on its own. Or maybe cause a content crash?
3. Visit http://www.google.com/m again and try to submit a search.

Actual Results:  
You can't submit the form.

Expected Results:  
Form gets submitted.
(Reporter)

Comment 1

6 years ago
Killing Fennec with the task manager and restarting it returns you to the form page, and you'll be able to submit it. You lose the information you filled out before though \:
OS: Linux → Android
Hardware: Other → ARM

Comment 2

6 years ago
Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110620 Firefox/7.0a1 Fennec/7.0a1

Device: HTC Desire Z (Android 2.2)

I can reproduce this always, following the steps:

1. Open approximately 20 tabs or more.
2. Load www.google.com. Make sure mobile version is loaded. (The classic version it worked fine)
3. Type in a search word and press the button search.

Actual result:
The button is not functional. Also when loading a webpage after 20 or more tabs have been already opened, the webpage may be just a blank page.

Expected results:
The search should be performed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Possible duplicate bug 676705 has an error log message that might be relevant.
See Also: → bug 676705
Possibly not the same bug, but I fairly frequently encounter forms that I cannot submit. If I change the orientation of the device so that the display rotates between portrait/landscape, I am often able to proceed with the submit. I haven't filed because I don't have good STR.
You need to log in before you can comment on or make changes to this bug.