Last Comment Bug 659580 - Flush CanvasImageCache from xpcom shutdown
: Flush CanvasImageCache from xpcom shutdown
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Peter Van der Beken [:peterv]
:
Mentors:
Depends on:
Blocks: 637099
  Show dependency treegraph
 
Reported: 2011-05-25 01:34 PDT by Peter Van der Beken [:peterv]
Modified: 2011-06-09 08:00 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (3.94 KB, patch)
2011-05-25 01:40 PDT, Peter Van der Beken [:peterv]
roc: review+
Details | Diff | Splinter Review

Description Peter Van der Beken [:peterv] 2011-05-25 01:34:02 PDT
This doesn't fix any real leaks, but it makes debugging slightly easier. The problem is that if you quit the browser before all cache items have expired we leak the cache (cache holds elements and is deleted from nsLayoutStatics::Shutdown which gets called after all elements have gone away).
Comment 1 Peter Van der Beken [:peterv] 2011-05-25 01:40:40 PDT
Created attachment 535005 [details] [diff] [review]
v1
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-06 16:33:22 PDT
Comment on attachment 535005 [details] [diff] [review]
v1

Review of attachment 535005 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 3 Peter Van der Beken [:peterv] 2011-06-09 08:00:32 PDT
http://hg.mozilla.org/mozilla-central/rev/5229dcb70989

Note You need to log in before you can comment on or make changes to this bug.