focusedWindow.location JS error when reloading frames.

RESOLVED DUPLICATE of bug 69712

Status

RESOLVED DUPLICATE of bug 69712
18 years ago
5 years ago

People

(Reporter: shawn, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
If you go to the above site, the site loads with no JavaScript errors.  However, 
if you right-click in the left frame and go to "Reload Frame", two of the same 
JavaScript errors pop-up:

Error: focusedWindow.location has no properties.
Source File: chrome://navigator/content/navigator.js
Line: 137                   Column: 0

Then another one just like it.
(Reporter)

Comment 1

18 years ago
On second thought, it looks like it happens if you right click in any of the 
frames and go to "Reload Frame".  Same thing each frame, each time.  Those same 
two JavaScript errors.

Comment 2

18 years ago
I get no errors. Tried all frames and they all reload without a problem.
Mozilla 2001011820 on Windows 2000 SP1.
(Reporter)

Comment 3

18 years ago
I'm trying it on Mozilla 2001011904 and still having the problem.  You reload
the frame and it displays fine, yes.  But, two of the same JavaScript error pops
up in the console.

Error: focusedWindow.location has no properties
Source File: chrome://navigator/content/navigator.js
Line: 82			Column: 0

On Mozilla 0.7 it was line 137, now it's line 82 with this latest build.

Comment 4

18 years ago
Try creating a new profile and see if that fixes it.
(Assignee)

Comment 5

18 years ago
I see the console errors. adding blake.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

18 years ago
I also filed a bug about this issue weeks ago. My bug is marked as fixed, but
it's still not fixed. I see a lot of those navigator.js errors in frames.

But lately there's another error: window.offlineObserver line 530 and that one
is new to me!

Comment 7

18 years ago
I am having the same problem, even in Mozilla 0.8.1.
However, I am getting the error on JavaScript code which looks like this:

opener.location.reload();

(Called from a new window opened by the page)

Comment 8

18 years ago
See also bug 69712, which reports a similar error in the JS console and also
involves frames.

Comment 9

18 years ago
Either this bug should be a dup of bug 69712 or vice versa.
(Assignee)

Comment 10

17 years ago

*** This bug has been marked as a duplicate of 69712 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.