Last Comment Bug 659675 - --with-system-png fails with libpng-1.4+
: --with-system-png fails with libpng-1.4+
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Mikhail T.
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-25 10:07 PDT by Mikhail T.
Modified: 2011-12-12 11:20 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use NULL instead of the no longer defined "png_voidp_NULL" (471 bytes, patch)
2011-05-25 10:07 PDT, Mikhail T.
no flags Details | Diff | Splinter Review

Description Mikhail T. 2011-05-25 10:07:46 PDT
Created attachment 535111 [details] [diff] [review]
Use NULL instead of the no longer defined "png_voidp_NULL"

png_voidp_NULL is not defined in modern libpng and various people recommend using NULL or 0:

https://bbs.archlinux.org/viewtopic.php?id=90268
https://bugs.webkit.org/show_bug.cgi?id=33287

In my opinion, NULL is the correct value...
Comment 1 Mark Banner (:standard8) (afk until 26th July) 2011-05-26 01:22:26 PDT
Since this is in ImageLib, moving to a more appropriate product/component.
Comment 2 Glenn Randers-Pehrson 2011-07-28 12:08:29 PDT
Comment on attachment 535111 [details] [diff] [review]
Use NULL instead of the no longer defined "png_voidp_NULL"

This change was made some time ago in mozilla-central.  The png_voidp_NULL constant was changed to nsnull.
Comment 3 Joe Drew (not getting mail) 2011-12-12 11:01:02 PST
Comment on attachment 535111 [details] [diff] [review]
Use NULL instead of the no longer defined "png_voidp_NULL"

Glenn's right - this patch is implicitly already applied, as we fixed this problem in another bug (which I can't find right now).

Mikhail, thanks for the patch!

Note You need to log in before you can comment on or make changes to this bug.