Last Comment Bug 659676 - [trunk] Build process is broken while processing creating gfx/ots/src/Makefile - related to bug 562746 ?
: [trunk] Build process is broken while processing creating gfx/ots/src/Makefil...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla7
Assigned To: Jeff Muizelaar [:jrmuizel]
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 562746
  Show dependency treegraph
 
Reported: 2011-05-25 10:08 PDT by Frederic Bezies
Modified: 2011-05-27 08:50 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove debugging code that snuck in (548 bytes, patch)
2011-05-25 21:54 PDT, Jeff Muizelaar [:jrmuizel]
khuey: review+
Details | Diff | Splinter Review

Description Frederic Bezies 2011-05-25 10:08:00 PDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110524 Firefox/7.0a1
Build Identifier: 

Getting this error while trying to build firefox trunk code.

nsIExtendedExpatSink.idl
creating gfx/harfbuzz/src/Makefile
creating gfx/ipc/Makefile
creating gfx/ots/src/Makefile
cat: cairo-dwrite-font.i: Aucun fichier ou dossier de ce type
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python3.2/base64.py", line 315, in encode
    s = input.read(MAXBINSIZE)
  File "/usr/lib/python3.2/codecs.py", line 300, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf8' codec can't decode byte 0x8b in position 1: invalid start byte
make[4]: *** [cairo-features.h] Erreur 1
make[3]: *** [export] Erreur 2
make[2]: *** [export] Erreur 2
make[1]: *** [export] Erreur 2
make: *** [depend] Erreur 2

I know that python3 is not supported but this error happens also with python2, using this value in .mozconfig

export PYTHON=python2

Here is my .mozconfig :

#
# See http://www.mozilla.org/build/ for build instructions.
#

export AUTOCONF=autoconf-2.13
export CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fpermissive"
export PYTHON=python2

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../objdir-fx
mk_add_options MOZ_MAKE_FLAGS=-j4

# Options for ‘configure’ (same as command-line options).
ac_add_options --enable-application=browser
ac_add_options --enable-optimize
ac_add_options --disable-debug
ac_add_options --disable-tests
ac_add_options --disable-crashreporter
ac_add_options --with-ccache
ac_add_options --disable-installer
ac_add_options --disable-warnings-as-errors

Reproducible: Always

Steps to Reproduce:
1. Grab recent trunk code
2. make -f client.mk depend
3. wait a little

Actual Results:  
Error in build process, see description.

Expected Results:  
build process going on.

Really recent problem. I can get source code to get build a few hours ago. Could it be a Cairo 1.10 landing related bug, bug #562746
Comment 1 Frederic Bezies 2011-05-25 21:51:18 PDT
Looks like bug #526476 is related to this bug.

http://hg.mozilla.org/mozilla-central/diff/acb4e51fa8a6/gfx/cairo/cairo/src/Makefile.in

1.120 +	cat cairo-dwrite-font.i | gzip | python -c "import base64,sys; base64.encode(sys.stdin,sys.stdout)"
Comment 2 Jeff Muizelaar [:jrmuizel] 2011-05-25 21:53:22 PDT
Yes, sorry that stuff should be taken out.
Comment 3 Jeff Muizelaar [:jrmuizel] 2011-05-25 21:54:50 PDT
Created attachment 535268 [details] [diff] [review]
remove debugging code that snuck in
Comment 4 Frederic Bezies 2011-05-25 21:56:17 PDT
I could work around it renaming python -> python2. Anyway, if this bug wasn't mean to be landed...
Comment 5 Dão Gottwald [:dao] 2011-05-26 01:50:25 PDT
http://hg.mozilla.org/mozilla-central/rev/ecbe9bb3433f
Comment 6 Frederic Bezies 2011-05-26 11:05:05 PDT
Thanks for the quick fix !
Comment 7 :Ehsan Akhgari 2011-05-26 12:00:21 PDT
I had to backout this bug because I needed to backout the Cairo update itself.  I will reland this if we decide to reland the Cairo update patch as it is.

http://hg.mozilla.org/mozilla-central/rev/08af2892e17c
Comment 8 :Ehsan Akhgari 2011-05-27 08:50:04 PDT
Relanded: http://hg.mozilla.org/mozilla-central/rev/04e8d0b481bc

Note You need to log in before you can comment on or make changes to this bug.