Long sidebar titles do not crop

VERIFIED FIXED in mozilla0.8.1

Status

SeaMonkey
Themes
P2
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: GAThrawn, Assigned: Joe Hewitt (gone))

Tracking

({classic})

Trunk
mozilla0.8.1
x86
Windows NT
classic

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
If you add a sidebar with a long title eg the one at
http://www.mydigiguide.com/, installable by clicking on the 'Add tab to netscape
6' button, and the bar is shorter than the title, it runs out into adjacent
chrome space. This only seems to happen on the Classic and not the Modern skin.

Steps to reproduce:
1 Open browser, make sure you're using Classic skin.
2 Go to the above URL and click the button to add the sidebar tab.
3 Move the new tab to the bottom of the list, and close it by selecting a
different tab on the sidebar.
4 Grab the vertical grippie on the sidebar and resize it so that it is smaller
than the tab's title.

Actual Result
The tab's title runs over into the adjacent chrome space (in this case the
Online/Offline indicator)

Expected Result
The tab's title is cropped to the available space

Reproducible on Win NT4 Mozilla 0.7, will try with newer build later on this
evening.

Comment 1

18 years ago
-> hewitt
Assignee: matt → hewitt
Status: UNCONFIRMED → NEW
Component: Sidebar → Themes
Ever confirmed: true
Keywords: classic
QA Contact: shrir → pmac
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
(Reporter)

Comment 2

18 years ago
Also happens with Mozilla build 20010117 Win 98SE.
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 3

18 years ago
I have a fix, but it's definitely a hack.  In the XBL binding for sidebar tabs,
I had to put the text element inside a vertically-oriented box.  If the parent
of the text is horizontally-oriented, the text does not crop.

Ideally this hack wouldn't be needed.  Perhaps I'll file a separate bug against
layout.
Target Milestone: mozilla0.9 → mozilla0.8.1
(Assignee)

Comment 4

18 years ago
Created attachment 27335 [details] [diff] [review]
patch to fix

Comment 5

18 years ago
Any reason we explicitly want a vertical box?

Comment 6

18 years ago
r=andreww although this does sound hacky.  
Seems like we are depending on the  effect of some incorrect behavior which might 
change later.  But there are lots of other cases like this.
(Assignee)

Comment 7

18 years ago
Blake, there is no good reason to have a vertical box, other than because it
fixes this bug ;)  It's just a workaround.

Comment 8

18 years ago
Do I hear mindless, illogical, nonsensical hackishness?

If so, r=blake
(Assignee)

Comment 9

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 10

18 years ago
Verified on windows 98 (2001-03-26-09-Mtrunk).
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.