If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make Mozilla the team of innovative leaders, instead of the team trying to be like the innovative leaders.

RESOLVED INVALID

Status

Mozilla Developer Network
General
--
enhancement
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: Navid Zamani, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20110520 Firefox/4.0.1
Build Identifier: * (everything)

This is a bug about the Mozilla community. Especially the deciders.
I didn’t know where else to put it, but it’s definitely a very important bug. A social one. A psychological one.

As someone who knows a lot about the psychology behind this, I can tell you that this is not meant as a trolling, nor as a insult or as a joke. It’s not attacking, but has the goal to improve the lives and works of the entire community, and all the users of the resulting works.
So even if your alarm triggers go off: This reaction is entirely normal, if one’s self-confidence looks like it’s attacked. Please hear me out anyway. As I respect you, and want to help rather than attack. Otherwise I wouldn’t care so much.

I’ll start like this:
What we see more and more, with Firefox & co, in the last time, is an apparent need, to change things in a certain way, that has a pattern of copying ideas of others, and ignoring that it alienates its users.
How and why is this ignored? Why is this happening?

Looking at the copying: If someone copies someone else, it nearly always is, because the copier feels that the original is superior to his ideas, which he sees as inferior.
This might well be the case. But in this case, it clearly isn’t, as the copied ideas are usually shunned and hated, even by those who previously apparently demanded it loudly.

So how come it’s done anyway? While clear evidence of it being a bad choice, is ignored?
Well, in psychology, we call this – and please don’t be offended, since I myself was a long-time victim of this, and it’s a extremely common thing for geeks — a “inferiority complex”.
Which interestingly, smart people are more susceptible for. (This is known as the Dunning-Kruger effect.)

The reason for this, according to current theories, is that we geeks usually are the weaker and more “un-cool” types in school. Getting bullied by the stronger sports-type guys, etc.
So we start to assume a insecure inferior follower role very early. While the bullies grow up to be “superior” “natural” leaders.
And us trying to be loved and accepted way too hard in the following years, makes it even worse, until it’s deeply ingrained into our behavior.

Even when we were actually superior all along, and now do the cool things, while the leader types either become managers… or burger flippers.

While we, today, still try to be accepted. But more importantly still don’t trust ourselves, and still don’t dare to go out there, and declare our own awesome ideas as /awesome/.
The difference to the copying of mediocre to bad ideas, is that this security and genuine enthusiasm drags people is. They get excited too.
It’s true leadership, and it’s the whole reason Steve Jobs’s product introduction events are so successful, that they created what is now officially declared a cult. (In case you missed the news. ;)

The thing is – and this is backed by decades of experience and studies in social dynamics and psychology – that this all… what we thought would be us… is actually something, we can change whenever we want. It’s not hard-wired. It’s just somewhat ingrained.
But: If the decision is made, to change it, usually it doesn’t stop until the end. Because it becomes a natural trigger, that is fired every time the old behavior kicks in. Until nothing of it is left, and the new behavior is always active. This elegantly compensates for it being ingrained.

⃗≫≫≫ So please… dare to make drastic changes! …but do it because of genuine enthusiasm and the self-security in your very own superiority, based on actually having those superior ideas.
Don’t try to be “as good” as someone else. Don’t even /try/ to be *better*. ≫ BE(COME) *better*. :)

That is all I have to say. I hope I inspired someone, to allow himself, to be as awesome, as he can be. And I hope I made everyone… users and developer alike… a bit happier in their lives, and with their Mozilla services.

And maybe, just maybe, Firefox will rule the world. :)

Reproducible: Always

Steps to Reproduce:
1. Find a big change in e.g. Firefox in the last 12 months. (E.g. the status bar removal, the URL bar removal plans.)
2. Look at the reaction of the users throughout the net.
3. Look at the complete ignorance of the users in following decisions.

Actual Results:  
Mozilla itself degrades its works to second class, by taking the role of a follower of “trends” & co, alienating the biggest part of its user base for the sake of the small lower-end of the Gaussian distribution curve that consists of the loudest and the dumbest ones, until people switch to what will have become the “original”, while the loudest and dumbest ones will still complain. For making life so hard, by them having to breathe, eat, ****, and use a computer... all by themselves *gasp*.

Expected Results:  
Mozilla takes a leadership position, by having the balls and spine, to stand for something efficient rather than just simple without power, and not looking at others, but having others look at itself.
Like Apple, minus the evilness, and minus the catering to that lowest end, but instead to all people, quiet too, and the neglected and insulted smart ones.
See https://groups.google.com/forum/#!topic/mozilla-labs-concept-series/miqfmABwI6Q for a better forum for this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Component: Engagement → Other
You need to log in before you can comment on or make changes to this bug.