Incorrect User Agent String [Resolved by resetting an entry in about:config]

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: jpdeveau, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.11) Gecko/20100701 Firefox/3.5.11 WebMoney Advisor
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.11) Gecko/20100701 Firefox/3.5.11 WebMoney Advisor

Reports Firefox/3.5.11 as you see about.
WRONG!
This is ver 4.0.1, the most recent available.

Reproducible: Always

Steps to Reproduce:
Try to install an add-on, reports wrong version asks you to upgrade.

OR

Use bugzilla... installed version id report incorrectly.



Expected Results:  
Reported I have version 4.0.1 an allowed me to install the plug-in for FFv4.
Reported the correct version in BugZilla.

I have reinstalled from the website 10 minutes ago.
No fix.
(Reporter)

Updated

8 years ago
Version: unspecified → 4.0 Branch
(Reporter)

Comment 1

8 years ago
Created attachment 535165 [details]
Notice the version numbers.....
I suspect that whatever put "WebMoney Advisor" into your user agent may be the culprit.

In about:config <http://kb.mozillazine.org/About:config#Opening_about:config>, try filtering for "useragent". If any preferences are bold (the status will be "user set"), right-click each and choose Reset.

If Firefox still reports the wrong user-agent string, use Safe Mode <http://support.mozilla.com/en-US/kb/Safe%20Mode>. If it works in Safe Mode, an add-on is the culprit.

You can perhaps disable each add-on in turn to work out which one it is. When you do, please let us know and we may be able to get it fixed.
(Reporter)

Comment 3

8 years ago
I'll be damned.... that worked. I reset that value and it works.
Wow.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 4

8 years ago
Changing status from FIXED to INVALID since no code has been checked into the tree.
Resolution: FIXED → INVALID
Summary: FIREFOX VERSION INCORRECT. → Incorrect User Agent String [Resolved by resetting an entry in about:config]
You need to log in before you can comment on or make changes to this bug.