Cmd+Shift+R resulted in the reply window showing the mail start page

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 535174 [details]
Screenshot

I got this when I was trying to reply to all on a message.  See the screenshot.

Other attempts at reproducing this were unsuccessful.

Here are the possible relevant error console entries:

Error: gMsgCompose is null
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 3954

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsILocalFile.create]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/FileUtils.jsm :: FileUtils_getDir :: line 64"  data: no]
Source File: resource://gre/modules/FileUtils.jsm
Line: 64

Error: formatURL: Couldn't find value for key: TIME_SESSION_RESTORED
Source File: resource://gre/components/nsURLFormatter.js
Line: 131

Comment 1

8 years ago
my guess would be necko disk cache corruption
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> my guess would be necko disk cache corruption

How come?

Comment 3

8 years ago
because reply runs a url to quote the original message; that url will use the disk cache, and the disk cache also stores the start page. Given that the url to fetch the message actually gave you the contents of the start page, it seems likely that it came from the disk cache. Also, there are lots of corruption issues with the disk cache.
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> because reply runs a url to quote the original message; that url will use the
> disk cache, and the disk cache also stores the start page. Given that the url
> to fetch the message actually gave you the contents of the start page, it seems
> likely that it came from the disk cache.

Could the js errors in comment 0 be relevant?

> Also, there are lots of corruption
> issues with the disk cache.

Does the Necko team know about them?

Comment 5

8 years ago
(In reply to comment #4)

> 
> Could the js errors in comment 0 be relevant?
I suspect they're a result of trying to treat the start page content as a message.
> 

> Does the Necko team know about them?

Yes, I only learned about them by trawling through bugzilla for necko cache bugs. I don't have a list handy, but there were a number of them.

Comment 6

4 years ago
Ehsan, have you ever seen this again?
Flags: needinfo?(ehsan.akhgari)
(Reporter)

Comment 7

4 years ago
No.
Flags: needinfo?(ehsan.akhgari)

Comment 8

4 years ago
Thanks, please update if it recurrs
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.