Last Comment Bug 659821 - Replace nsContentUtils::GetLocalizedStringPref() with Preferences::GetLocalizedCString() or Preferences::GetLocalizedString()
: Replace nsContentUtils::GetLocalizedStringPref() with Preferences::GetLocaliz...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
:
Mentors:
Depends on: 656826 660401
Blocks: 660121
  Show dependency treegraph
 
Reported: 2011-05-25 16:53 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
Modified: 2011-05-27 19:27 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part.1 Add GetLocalizedString() for nsACString (2.08 KB, patch)
2011-05-25 16:53 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
roc: review+
Details | Diff | Review
Part.2 Replace (20.65 KB, patch)
2011-05-25 16:54 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
roc: review+
Details | Diff | Review
Part.2 Replace with direct return methods (20.21 KB, patch)
2011-05-26 05:59 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
no flags Details | Diff | Review
Repace them (20.23 KB, patch)
2011-05-26 20:15 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
roc: review+
Details | Diff | Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-05-25 16:53:08 PDT
Created attachment 535232 [details] [diff] [review]
Part.1 Add GetLocalizedString() for nsACString
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-05-25 16:54:13 PDT
Created attachment 535233 [details] [diff] [review]
Part.2 Replace
Comment 2 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-05-25 17:17:18 PDT
Comment on attachment 535232 [details] [diff] [review]
Part.1 Add GetLocalizedString() for nsACString

Review of attachment 535232 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-05-25 17:21:33 PDT
Comment on attachment 535233 [details] [diff] [review]
Part.2 Replace

Review of attachment 535233 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-05-25 17:31:54 PDT
Actually, see bug 659820 ... it would be ideal if we can make this API return a string directly, if we can make that efficient.
Comment 5 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-05-26 05:59:37 PDT
Created attachment 535311 [details] [diff] [review]
Part.2 Replace with direct return methods
Comment 6 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-05-26 17:04:59 PDT
We need a new version of part 1, don't we?
Comment 7 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-05-26 18:07:41 PDT
(In reply to comment #6)
> We need a new version of part 1, don't we?

Actually, no. The order of patches in my queue is:

bug 659820 part.1
bug 659821 part.1
bug 659820 part.2

The bug 659820 part.2 renames GetLocalizedString() to GetLocalizedCString().
Comment 8 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-05-26 18:08:34 PDT
I think you don't like the messy order, I'll merge bug 659821 part.1 and bug 659820 part.2.
Comment 9 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-05-26 19:48:36 PDT
Comment on attachment 535232 [details] [diff] [review]
Part.1 Add GetLocalizedString() for nsACString

(In reply to comment #8)
> I think you don't like the messy order, I'll merge bug 659821 part.1 and bug
> 659820 part.2.

Simply, the part.1 of this bug is moved to bug 659820 as part.2.
Comment 10 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-05-26 20:15:44 PDT
Created attachment 535549 [details] [diff] [review]
Repace them
Comment 11 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-05-26 20:18:23 PDT
Comment on attachment 535549 [details] [diff] [review]
Repace them

Review of attachment 535549 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 12 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-05-26 21:55:32 PDT
http://hg.mozilla.org/mozilla-central/rev/ff89f3047bd5

Note You need to log in before you can comment on or make changes to this bug.