Unable to view .aspx file extensions in browser window

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: James, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When trying to view a .aspx file/link extension FF requests action to be taken in the download manager and won't open the file in a new/current tab or a new window.  This is a FF specific bug as when selecting the .aspx file/link in Safari or Chrome the file is loaded directly into a new tab/window.

Please resolve this FireFox or I will be forced to transfer browsers! 

Reproducible: Always

Steps to Reproduce:
1. Open FF 4.0.1 in Mac OSX
2. Navigate to a website that contains .aspx files/links (unable to provide full step due to personal data)
3. Select the .aspx link or file

Actual Results:  
FF requests action to be taken and won't render the file in the FF browser.

Expected Results:  
.aspx file to render in FF session and act as a file viewer as it does in all other browsers.

Comment 1

7 years ago
Is there a link which demonstrates this behaviour?
Is this a problem in Firefox's safe mode? http://support.mozilla.com/en-US/kb/Basic troubleshooting#w_4-restart-firefox-in-safe-mode

Comment 3

7 years ago
Can you provide a link?
Thx
(Reporter)

Comment 4

7 years ago
FireFox isn't in safe mode, it's running on OSX 10.6.7

Unfortunately I can't provide you with a link as it's for a site that you must have a username and password for.  The only way I am able to view the file is to open as a PDF.  I will try and replicate with a different file and update the bug.

Comment 5

7 years ago
I've got the same problem with windows 7 Firefox 4.0.1 it hung on https://www.clove.co.uk/checkout3.aspx with a "please wait" displayed for an hour, restarted firefox and same thing. Internet Explorer 9 passed this point without issue. It is the page before payment so can be tested. The strange thing is https://www.clove.co.uk/checkout2.aspx and checkout1.aspx all proceed correctly before the checkout3 step.

Comment 6

7 years ago
Reporter, does the issue still occurs on the latest Firefox? (Fx5)
(Reporter)

Comment 7

7 years ago
No, just tested with the latest update and it still happens! It's really frustrating, every other browser is able to render these files but one of the biggest browsers in the world can't!

Comment 8

6 years ago
Reporter, is the issue still occurring? 
Can you please try to reproduce this on Firefox 6b5:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/6.0b5/mac/en-US/

Comment 9

6 years ago
Reporter, do you have anything new about this issue?
(Reporter)

Comment 10

6 years ago
Created attachment 559297 [details]
Screen grab of download request
(Reporter)

Comment 11

6 years ago
Issue still present and I have updated FF to the latest version.  See uploaded image, every time I try to open the aspx file I get this prompt, this only happens with FF, Safari and Chrome render the file into a new tab.

Comment 12

6 years ago
It will be great if you can provide a aspx test file.
Thanks.

Comment 13

6 years ago
Same here. Test with that site: www.anpfiff.info or http://www.anpfiff.info/sites/home/home.aspx.

Comment 14

6 years ago
I use beta version of firefox mobile and the normal version (from Januar 31).
Works for me with latest Aurora 28.0a2 (build ID: 20131223004002) in 32-bit mode, on Mac OS X 10.6.8

All of the 3 below listed pages are loading as expected:

https://live.sagepay.com/gateway/service/cardselection?vpstxid={B1C25B18-35FA-5B2A-E342-C51CB61B4358}
https://www.clove.co.uk/checkout2.aspx
http://www.anpfiff.info/sites/home/home.aspx

Please reopen the bug if you can still reproduce the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.