Closed Bug 659826 Opened 9 years ago Closed 9 years ago

Crash [@ nsAString_internal::SetLength(unsigned int)]

Categories

(Core :: Disability Access APIs, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 659620

People

(Reporter: james, Unassigned)

References

()

Details

(Keywords: access, crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110525 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110525 Firefox/7.0a1

Loading the page linked to above causes Nightly to crash, but only when a screen reader (NVDA and JAWS have been tested) is running.  If I unload the screen reader and open the page, no crashes or errors occur, however as soon as I reload my screen reader with the page open, Nightly crashes again.  This problem occurs both in regular usage mode and in safe mode without add-ons enabled.

Reproducible: Always

Steps to Reproduce:
1. Load a screen reader (I've tried NVDA and JAWS)
2. Visit http://forum.soundarea.org.  Nightly crashes.
3. Quit Nightly and unload the screen reader.  When you load the same page, no errors or crashes should be encountered.
4. Load the screen reader back up again while the page is still open in Nightly.  The browser once again crashes.

Actual Results:  
See issue details and steps above.

Expected Results:  
Complete loading of page with no crashes or errors.

bp-12d8551c-7ae8-4b60-9501-b09112110525
Version: unspecified → Trunk
Component: Disability Access → Disability Access APIs
Keywords: access, crash
Product: Firefox → Core
QA Contact: disability.access → accessibility-apis
I can't reproduce this. Do you know if you were perhaps persistently logged in?
Summary: Loading the page linked to above causes Nightly to crash, but only when a screen reader (NVDA and JAWS have been tested) is running. → Crash [@ nsAString_internal::SetLength(unsigned int) ]
Summary: Crash [@ nsAString_internal::SetLength(unsigned int) ] → Crash [@ nsAString_internal::SetLength(unsigned int)]
(In reply to comment #1)
> I can't reproduce this. Do you know if you were perhaps persistently logged
> in?

FROM THE STACK ITS CERTIANLY POSSIBLE TO HAVE A PROBLEM HERE, BUT IT'LL BE FIXED BY THE PATCH IN BUG 659630, WHICH i'M GOING TO LAND VERY SOON :)
Trevor, make that bug 659620. ;) I also cannot reproduce just by going to that page, but I'm not logged in, either.
Depends on: 659620
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 659620
Crash Signature: [@ nsAString_internal::SetLength(unsigned int)]
You need to log in before you can comment on or make changes to this bug.