Firefox 5 Beta - 'Not Responding' after a period of idle

RESOLVED INCOMPLETE

Status

()

--
critical
RESOLVED INCOMPLETE
7 years ago
6 years ago

People

(Reporter: ian.seale, Unassigned)

Tracking

5 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.0; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (Windows NT 5.0; rv:5.0) Gecko/20100101 Firefox/5.0

Running Firefox 5 Beta (a massive improvement over FF 4)

I've started to notice FF failing to respond.
During the problem the hardisk is constantly writing.
Firefox has only 3 tabs up: BBC News, Facebook and Equity.org
The only other application running is Outlook.

Firefox memory usage is around 117,000 whilst it 'fails to respond'

Reproducible: Sometimes

Steps to Reproduce:
1. Problem seems to occur after a period of idle (30 minutes plus)
2. Unrepeatable, under user control.
3.

Actual Results:  
Only solution to the 'Failing to respond' is to shut down and re-start Firefox.
Immediately Firefox is shut down the harddisk stops writing.
(Reporter)

Updated

7 years ago
Summary: Firefox 5 Beta - 'Not Repsonding' after a period of idle → Firefox 5 Beta - 'Not Responding' after a period of idle

Comment 1

7 years ago
Does the issue still occur if you start Firefox in Safe Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode

You may try Process Monitor (Tools/File summary...) and see what causes the disk activity.
http://technet.microsoft.com/en-us/sysinternals/bb896645
Version: unspecified → 5 Branch
(Reporter)

Comment 2

7 years ago
Thomas,

Thanks for those links.  I tried Process monitor, but it wouldn't run - my operating system is Windows 2000 (yeah, I know) but not always the source of the problem an older operating system, and why should it be?

I ran is Safe Mode for a bit, but the 'Failing to respond' occurs after some time and, although I'm interested in the diagnosis, it appeared to work in a similar fashion for the hour or so I had it running - the problem was occurring well over an hour in and after a period of idle - and I've had work to do this afternoon.

If there was a way to display my Plug-Ins and Extensions here, I'd do so, in case there are any that are well know to create problems.

Until then, I'll try and gather more data as things progress.

Comment 3

7 years ago
You can view and copy the extensions if you write about:support in the address bar.

Another thing to try can be to test with a new, empty profile.
https://support.mozilla.com/en-US/kb/Basic+Troubleshooting#w_8-make-a-new-profile
(Reporter)

Comment 4

7 years ago
Thanks Thomas, these are the extensions that I am running (Greasemonkey disabled in FF 5)

Adblock Plus
BetterPrivacy
British English Dictionary
F.B. Purity
Java Console
Java Quick Starter
TACO with Abine
Greasemonkey

Comment 5

6 years ago
Ian, do you stilll see this when using version 13 or newer?
Whiteboard: [closeme 2012-07-08]
(Reporter)

Comment 6

6 years ago
I gave up on 5 as well as 4 before it and reverted to 3.6.24
3.6.24 has now been made obsolete by Mozilla and I'm running FF 11 - I cannot run 12 or above as these newer version will not work with any operating system below XP (I'm still using Win 2000).
The FF 11 browser is a challenge for my machine, and I still do get 'failures to respond' while the hard-disk spins away.
FF just seems to want to eat memory sometimes.
Anyhow FF11 is better and the problem is worse on my machine with less RAM.

Comment 7

6 years ago
Not mentioning about ESR branch, you can use current release Firefox versions in w2k, read this topic - http://forums.mozillazine.org/viewtopic.php?f=23&t=2482475

Comment 8

6 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-07-08]
You need to log in before you can comment on or make changes to this bug.