Flash crashes in Medium Size Mode on any YouTube Video [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_SetWindow(mozilla::plugins::NPRemoteWindow const&) ]

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Aaron, Unassigned)

Tracking

({crash, flashplayer})

Trunk
x86
Windows XP
crash, flashplayer
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110526 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110526 Firefox/7.0a1

After downloading and installing the update on 5/25/11 Mozilla Nightly keeps crashing on YouTube when YouTube screen size is in Medium Size screen mode.  Update for 5/26/11 still has this bug.  It will load the video and start playing the video.  But once you go to click the pause button, change screen size excedra.  The video will then freezes and stay's frozen for a little bit then it crashes.  Flash version 10.13.181.14... Shockwave version 11.5.9.620...  Please fix this issue.  Thank you...

Reproducible: Always

Steps to Reproduce:
1.Go to any YouTube video on YouTube then click it to open it.
2.Then expand it from Small size to Medium size play it.
3.After doing that flash will crash every single time

Actual Results:  
The results is I get the Adobe Plugin crash error.  Example is here on this Mozilla page.  http://support.mozilla.com/en-US/kb/Plugin%20crash%20reports?as=u

Expected Results:  
It should play without crashing

about:buildconfig
Source

Built from http://hg.mozilla.org/mozilla-central/rev/831f8e040f38
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-tests
(Reporter)

Updated

7 years ago
Keywords: flashplayer, shockwave
Priority: -- → P1

Comment 2

7 years ago
0 	ntdll.dll 	KiFastSystemCallRet 	
1 	ntdll.dll 	NtWaitForSingleObject 	
2 	kernel32.dll 	WaitForSingleObjectEx 	
3 	kernel32.dll 	WaitForSingleObject 	
4 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidumpOnHandlerThread 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:763
5 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidumpForException 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:778
6 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidump 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:820
7 	xul.dll 	CrashReporter::CreatePairedMinidumps 	toolkit/crashreporter/nsExceptionHandler.cpp:2074
8 	xul.dll 	mozilla::plugins::PluginModuleParent::ShouldContinueFromReplyTimeout 	dom/plugins/ipc/PluginModuleParent.cpp:261
9 	xul.dll 	mozilla::ipc::SyncChannel::ShouldContinueFromTimeout 	ipc/glue/SyncChannel.cpp:261
10 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:210
11 	xul.dll 	mozilla::plugins::PPluginInstanceParent::CallNPP_SetWindow 	obj-firefox/ipc/ipdl/PPluginInstanceParent.cpp:243
12 	xul.dll 	mozilla::plugins::PluginInstanceParent::NPP_SetWindow 	dom/plugins/ipc/PluginInstanceParent.cpp:898
13 	xul.dll 	mozilla::plugins::PluginModuleParent::NPP_SetWindow 	dom/plugins/ipc/PluginModuleParent.cpp:469
14 	xul.dll 	nsNPAPIPluginInstance::SetWindow 	dom/plugins/base/nsNPAPIPluginInstance.cpp:470
15 	xul.dll 	nsPluginNativeWindow::CallSetWindow 	dom/plugins/base/nsPluginNativeWindow.h:102
16 	xul.dll 	nsPluginNativeWindowWin::CallSetWindow 	dom/plugins/base/nsPluginNativeWindowWin.cpp:673
17 	xul.dll 	nsObjectFrame::CallSetWindow 	layout/generic/nsObjectFrame.cpp:1172
18 	xul.dll 	nsObjectFrame::ReflowFinished 	layout/generic/nsObjectFrame.cpp:1030
19 	xul.dll 	PresShell::HandlePostedReflowCallbacks 	layout/base/nsPresShell.cpp:4705
20 	xul.dll 	PresShell::ProcessReflowCommands 	layout/base/nsPresShell.cpp:8150
21 	xul.dll 	PresShell::FlushPendingNotifications 	layout/base/nsPresShell.cpp:4863
22 	xul.dll 	nsDocument::FlushPendingNotifications 	content/base/src/nsDocument.cpp:6399
23 	xul.dll 	nsFocusManager::CheckIfFocusable 	dom/base/nsFocusManager.cpp:1412
24 	xul.dll 	nsFocusManager::SetFocusInner 	dom/base/nsFocusManager.cpp:1072
25 	xul.dll 	nsFocusManager::SetFocus 	dom/base/nsFocusManager.cpp:466
26 	xul.dll 	nsObjectFrame::HandleEvent 	layout/generic/nsObjectFrame.cpp:2467
27 	xul.dll 	nsPresShellEventCB::HandleEvent 	layout/base/nsPresShell.cpp:1510
28 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:389
29 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:648
30 	xul.dll 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:7166
31 	xul.dll 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6901
32 	xul.dll 	nsViewManager::HandleEvent 	view/src/nsViewManager.cpp:1040
33 	xul.dll 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1018
34 	xul.dll 	HandleEvent 	
35 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:3582
36 	xul.dll 	PluginWndProcInternal 	dom/plugins/base/nsPluginNativeWindowWin.cpp:309
37 	xul.dll 	CallWindowProcCrashProtected 	
38 	xul.dll 	PluginWndProc 	dom/plugins/base/nsPluginNativeWindowWin.cpp:384
39 	user32.dll 	InternalCallWinProc 	
40 	user32.dll 	UserCallWinProcCheckWow 	
41 	user32.dll 	DispatchClientMessage 	
42 	user32.dll 	__fnDWORD 	
43 	ntdll.dll 	KiUserCallbackDispatcher 	
44 	xul.dll 	mozilla::plugins::PluginInstanceChild::PluginWindowProc 	dom/plugins/ipc/PluginInstanceChild.cpp:1181
45 	user32.dll 	TestWindowProcess 	
46 	user32.dll 	NtUserPeekMessage 	
47 	xul.dll 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:306
Keywords: crash
Summary: Flash crashes in Medium Size Mode on any YouTube Video → Flash crashes in Medium Size Mode on any YouTube Video [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_SetWindow(mozilla::plugins::NPRemoteWindow const&) ]
Version: unspecified → Trunk

Comment 3

7 years ago
Maybe bug 565708, comment 14, has something to do with this.

Comment 4

7 years ago
Same kind of crash in bug 658741, comment 4.
Component: Extension Compatibility → Plug-ins
Keywords: shockwave
Priority: P1 → --
Product: Firefox → Core
QA Contact: extension.compatibility → plugins
I tried reproducing using Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110526 Firefox/7.0a1 with Flash Version: 10.3.181.14, but so far no crashes.
(Reporter)

Comment 6

7 years ago
It seems to be working fine now.  I tried it last night and today and its working fine.  The time frame it was not working was the morning of 5/26/11.  I had installed the update before that and the one that was on the morning on the 26th   It might of bean YouTube just updating the site causing the flash player to crash.  But I will give it a week and if it is still operating properly I will come back with another comment in a week saying its working fine.

Comment 7

7 years ago
Bug 658741, comment 35, shows that a fix has been checked in and as already stated in comment 4, this bug a that bug have similar crash profiles.

However, some time zone confusion and my lack of knowledge about the production cycles of the Nigthlies make me unsure if you already should be able to benefit from that fix.

But this bug is most likely a duplicate of bug 658741 anyway.

Comment 8

7 years ago
Got this hang/crash as well on 3.6.17.
https://crash-stats.mozilla.com/report/index/bp-66d49440-5abc-4a72-89d6-912912110606

The relevant web page is:
http://www.tsf.pt/Programas/BlogsExternal.aspx?content_id=1015547&audio_id=1871142

Trying to play/pause and reloading will often cause this.

Comment 9

7 years ago
This dropped significantly along with the plugin-side hang signature in bug 618683 between the trunk builds from 2011-05-27 and 2011-05-28: -05-25 through -05-27 had way over 400 such hangs, while since the -05-28 builds, we have way below 100 such hangs reported per build. (Before -05-25, it wasn't 7.0a1 yet, so the data set I'm looking at right now only starts with that date.)

Whatever landed on trunk that day - the range is http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2011-05-27+03%3A00%3A00&enddate=2011-05-28+03%3A00%3A00 - seems to have significantly reduced those hangs. This range includes a major cairo update, not sure what else could have influenced this...

Comment 10

7 years ago
Got this crash spontaneously on two-days-old Aurora with newest Flash: https://crash-stats.mozilla.com/report/index/5b9dfc52-60d1-4c97-a5ff-28d412110609

Different trigger?

Comment 11

7 years ago
(In reply to comment #10)
> Different trigger?

No, probably exactly that problem. We seem to have had something on 7.0a1 that caused even more plugin hangs and that was fixed, but the original problem this was filed for is probably still around. It doesn't seem 100% sure though if Firefox or Flash code is the problem, though - actually, we apparently have no idea why this happens. :(

Comment 12

7 years ago
(In reply to comment #10)
> Got this crash spontaneously on two-days-old Aurora with newest Flash:
> https://crash-stats.mozilla.com/report/index/5b9dfc52-60d1-4c97-a5ff-
> 28d412110609

Oh, and just if anyone takes a look, bp-4cee3dee-41c3-4c16-89e1-da0b92110609 is the plugin side of this one.
(Assignee)

Updated

7 years ago
Crash Signature: [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_SetWindow(mozilla::plugins::NPRemoteWindow const&) ]
(Reporter)

Comment 13

7 years ago
I have been using YouTube for quite some time after I reported this bug and I have to come to the conclusion that it was nothing more then YouTube updating a portion of there website which caused the videos not to play and crash.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.