Use a read-only storage connection for read queries

RESOLVED DUPLICATE of bug 612766

Status

()

RESOLVED DUPLICATE of bug 612766
8 years ago
3 months ago

People

(Reporter: philikon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Should help with lock contention.
Created attachment 535456 [details] [diff] [review]
WIP. v1

This refactors some shared code out of BookmarksStore and HistoryStore into PlacesStore, and adds an indirection for connection fetching. This allows us to maintain a single read-only clone of the main Places DBConnection.

One test failure in test_history_store.js. Haven't investigated.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 612766
(Assignee)

Updated

3 months ago
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.