Youtube Playlists embed codes are not displayed

RESOLVED INVALID

Status

()

Core
Plug-ins
--
major
RESOLVED INVALID
7 years ago
2 years ago

People

(Reporter: Lenz Hirsch, Unassigned)

Tracking

5 Branch
x86
All
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [bugday-2011-05-27][parity-chrome][parity-opera] [platform-rel-Youtube])

Attachments

(1 attachment)

464 bytes, text/html
Details
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; de-de) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1
Build Identifier: 4.0.1

Youtube PLAYLIST embed codes like this are not displayed since FF Version 4:

<object width="480" height="385" type="application/futuresplash">
    <param name="movie" value="http://www.youtube.com/p/FE11CE11D5EA7D87?hl=de_DE&amp;fs=1" />
    <param name="allowFullScreen" value="true" />
    <param name="allowscriptaccess" value="always" /><embed type="application/futuresplash" width="480" height="385" src="http://www.youtube.com/p/FE11CE11D5EA7D87?hl=de_DE&amp;fs=1" allowscriptaccess="always" allowfullscreen="true"></embed>
    </object>



Reproducible: Always
(Reporter)

Comment 1

7 years ago
it works if you only use the embed part of the code above

<embed type="application/futuresplash" width="480" height="385" src="http://www.youtube.com/p/FE11CE11D5EA7D87?hl=de_DE&amp;fs=1" allowscriptaccess="always" allowfullscreen="true"></embed>

strange..

Comment 2

7 years ago
Is this the official recommended by youtube way of embedding the video?
Whiteboard: [bugday-2011-05-27]

Comment 3

7 years ago
Created attachment 535727 [details]
testcase
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a2) Gecko/20110527 Firefox/6.0a2

Tested the testcase and i don't see anything.

Comment 5

7 years ago
You should see a youtube video and should be able to see it. So you confirm it doesn't work. I confirm on FF 5.0b.

The testcase DOES work on Opera 11.10 and Chrome 12.0.742.12 dev on Linux. Confirming.
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 5 Branch
(Reporter)

Comment 6

7 years ago
(In reply to comment #2)
> Is this the official recommended by youtube way of embedding the video?

yes its the official way of embedding a youtube playlist. you can generate the code here: http://www.youtube.com/playlist?p=PLFE11CE11D5EA7D87

Comment 7

7 years ago
The issue is reproducible on:
Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.0

*Note: It's not clear if the code is supposed to work/support in Firefox or not, since it does not play in 3.6 build either.
(Reporter)

Comment 8

7 years ago
(In reply to comment #7)
> *Note: It's not clear if the code is supposed to work/support in Firefox or
> not, since it does not play in 3.6 build either.
Interesting. But if it does not support FF at all why is the embed code only version running then. It carries just the same data as the object code. Also a object code only version ist NOT working.

This one is working:
<embed type="application/futuresplash" width="480" height="385" src="http://www.youtube.com/p/FE11CE11D5EA7D87?hl=de_DE&amp;fs=1" allowscriptaccess="always" allowfullscreen="true"></embed>

This one is NOT:
<object width="480" height="385" type="application/futuresplash">
    <param name="movie" value="http://www.youtube.com/p/FE11CE11D5EA7D87?hl=de_DE&amp;fs=1" />
    <param name="allowFullScreen" value="true" />
    <param name="allowscriptaccess" value="always" />
</object>

Comment 9

7 years ago
The original reporter says it stopped working since FF4 so presumably it worked for him on 3.6.
Lenz Hirsch can you confirm that?
However regardless of that, other browsers do support this, so it is worth to investigate why they do it and if it is correct to do. So this bug is confirmed.

In reply to comment #8)
> This one is NOT:
> <object width="480" height="385" type="application/futuresplash">
>     <param name="movie"
> value="http://www.youtube.com/p/FE11CE11D5EA7D87?hl=de_DE&amp;fs=1" />
>     <param name="allowFullScreen" value="true" />
>     <param name="allowscriptaccess" value="always" />
> </object>
Wait, this is other code than you posted in the description. How comes?
Whiteboard: [bugday-2011-05-27] → [bugday-2011-05-27][parity-chrome][parity-opera]
(Reporter)

Comment 10

7 years ago
(In reply to comment #9)
My fault! I can not confirm that it did run on FF3.6. User complaints on our articles poped up arround the time FF4 was released. We rashly assumed Youtube playlist must have worked before.

My managing editor wanted a way to get the playlist running for all users quick.
So i played around a little bit with the code generated by Youtube.
I recognized that if i take the original Youtube code - wich is the following combined <object>/<embed> code:

<object width="480" height="385" type="application/futuresplash">
    <param name="movie" value="http://www.youtube.com/p/FE11CE11D5EA7D87?hl=de_DE&amp;fs=1" />
    <param name="allowFullScreen" value="true" />
    <param name="allowscriptaccess" value="always" /><embed type="application/futuresplash" width="480" height="385" src="http://www.youtube.com/p/FE11CE11D5EA7D87?hl=de_DE&amp;fs=1" allowscriptaccess="always" allowfullscreen="true"></embed>
</object>

and split it up in the <embed> and <object> parts like this:

<object width="480" height="385" type="application/futuresplash">
    <param name="movie" value="http://www.youtube.com/p/FE11CE11D5EA7D87?hl=de_DE&amp;fs=1" />
    <param name="allowFullScreen" value="true" />
    <param name="allowscriptaccess" value="always" />
</object>

<embed type="application/futuresplash" width="480" height="385" src="http://www.youtube.com/p/FE11CE11D5EA7D87?hl=de_DE&amp;fs=1" allowscriptaccess="always" allowfullscreen="true"></embed>

The lower pure <embed> code variant DOES work and the upper pure <object> variant does NOT.
Sorry for the confusion.

Comment 11

6 years ago
The embed code for playlists are now an iframe AFAICT. The problem probably still exists for older pasted embed codes though.

Updated

2 years ago
platform-rel: --- → ?

Updated

2 years ago
Whiteboard: [bugday-2011-05-27][parity-chrome][parity-opera] → [bugday-2011-05-27][parity-chrome][parity-opera] [platform-rel-Youtube]

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.